Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Tranny problems, Help!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Wingnutt, Nov 11, 2001.

  1. Wingnutt

    Wingnutt 1/2 ton status

    Joined:
    Feb 20, 2000
    Posts:
    324
    Likes Received:
    0
    Location:
    NOVA
    Yesterday my tranny (’88 700R4) started acting up. It would hold the 1st to 2nd shift to about 3000rpm before allowing it shift to second. It also would hold the 2nd to 3rd shift to about 2000rpm. When stopping, the blasted thing wouldn’t go into 1st every time. The fluid was very aerated, but not burned. The tranny man at the local Chevy dealer said that it sounded like the filter was stopped up and that some gunk had gotten into the valve body. Does this sound right? Opinions. Differing diagnosis? HELP!

    Yer born at point "A" & yer gonna die at point "B". Kick maximun arse in between.
     
  2. DesertDueler

    DesertDueler 1/2 ton status

    Joined:
    May 23, 2001
    Posts:
    3,106
    Likes Received:
    0
    Location:
    Phoenix, AZ
    The burbs tranny was doing that since I bought it. Now 600 miles later since I bought it the front seal blew out on it and destroyed the tranny. You can try the filter thing, but I was told the reson mine did that and blew the seal out is because the valve body was hanging up and after awhile of driving it built too much pressure, so when I was towing for about an hour, it built up too much pressure and blew the seal out :( You can put in a new valve body, but I would do something before it goes like mine.

    86Jimmy 4"&35"MTRs,87 burb 4"&35"MT,69Firebird w/525 hp,and 70GTO live in PHX,AZ<a target="_blank" href=http://www.geocities.com/modifierperformance>My vehicles</a>
     

Share This Page