Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

tranny problems

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by RAZORBLAZER, May 17, 2001.

  1. RAZORBLAZER

    RAZORBLAZER Registered Member

    Joined:
    Apr 24, 2001
    Posts:
    5
    Likes Received:
    0
    Location:
    nw arkansas
    I have a th350 on my 79 k5 it shifts fine when cool, but when it gets a little hot and you are in third and give it a little gas it slips into nuetral. If you shift into nuetral and back to drive it works until you give it too much gas. is this just a gov problem or more complex? I bought the blazer a couple of months ago and just started having problems yesterday. it is supposed to be a rebuilt tranny(the housing has been freshley painted anyway) the guy i bought it from was moving when i bought it so i can't find out who rebuilt it to ask them what all they did. thanks for any help.
     
  2. FRIZZLEFRY

    FRIZZLEFRY 1/2 ton status

    Joined:
    Apr 20, 2001
    Posts:
    3,271
    Likes Received:
    134
    Location:
    Clovis CA
    It sounds like a valve body problem possibly.Check your fluid.If its not burnt Iwould say its a control problem.Im a certified Ford trans tech but they all work prety much the same.Valve body removal is a whole lot easier than pullin your tranny only to find out you didnt have to.You could also do a pressure check if you can get a hold of a gauge.That could give you a clue of whats going on inside.Good luck.

    Proving once again that man CAN live on beer alone
     

Share This Page