Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Tranny shifting problems TH-400

Discussion in 'The Garage' started by DukeBoy88, Sep 6, 2004.

  1. DukeBoy88

    DukeBoy88 1/2 ton status

    Joined:
    Oct 16, 2002
    Posts:
    315
    Likes Received:
    0
    Location:
    Jonestown Pa
    I have a Jasper replacement TH-400 in my M1008. On the way home yesterday It started shifting eratically, holding the RPM's too long before shifting, sometimes shifting violently, sometimes very sluggish. I pulled over, fluid level was fine, smelled ok. I had changed fluid and filter when I got it 4000m ago. Once it shifted it behaved ok, except downhill coasting where it would stutter shift. I nursed it home, but haven't had a chance to check it out yet. It's still under waranty, but I don't want to take it in if it's something simple to check first. any ideas?
    thanks in advance.
     
  2. 84_Chevy_K10

    84_Chevy_K10 Banned

    Joined:
    May 30, 2001
    Posts:
    17,669
    Likes Received:
    0
    Location:
    IL, USA
    Is the vacuum line hooked to the modulator?
     
  3. Nonesuch

    Nonesuch 1/2 ton status

    Joined:
    Jul 16, 2001
    Posts:
    1,467
    Likes Received:
    0
    Location:
    Austin(Leander), TX
    The governor sounds like your culprit. It is on the back passenger side of the transmission under a cover with 4 bolts on it. Pull it out and soak it real good with brake cleaner. Make sure to dry it very well before re-installing it. Check to make sure it opens freely. If it doesn't open very well after a good cleaning, it needs to be rebuilt so get it back to the shop where you had the work done. The modulator could also be a problem as stated before this post. Check the line carefully for leaks and repair any you find. I would put my money on the governor.
     
  4. DukeBoy88

    DukeBoy88 1/2 ton status

    Joined:
    Oct 16, 2002
    Posts:
    315
    Likes Received:
    0
    Location:
    Jonestown Pa
    thanks guys, split vacuum line. quick fix /forums/images/graemlins/thumb.gif
     

Share This Page