Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Tranny went out! Need help!!!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Nrose07, Apr 8, 2002.

  1. Nrose07

    Nrose07 1/2 ton status

    Joined:
    Mar 29, 2000
    Posts:
    267
    Likes Received:
    0
    Location:
    Salem ,Or
    My buddies turbo 350 had a bad night. Lost second and third gear. He drove it home saturday and then this morning when he got in it poof, gone! This tranny has been very stout and reliable and this happened overnight, we both checked the vacum line, kickdown, fluid, everything. Everything is ok, first gear and reverse are good. It shifts into second and then slips like it is in neutral. There was no indication of anything, just plain lost 2nd and 3rd. Would love some help, since I'll do the work. 1978 chev 1/2 ton, 350/350/205, 4.56 gears and 38's.
     
  2. dragricinMT

    dragricinMT 1/2 ton status

    Joined:
    Jul 21, 2001
    Posts:
    135
    Likes Received:
    0
    Location:
    Billings Montana
    Check the vacuem modulator.
     
  3. 4X4HIGH

    4X4HIGH 1 ton status Premium Member GMOTM Winner

    Joined:
    Dec 14, 2001
    Posts:
    22,060
    Likes Received:
    69
    Location:
    Pleasanton, CA.
    Check for a sticky governor valve. I would first drop the tranny pan and check and change the filter and fluid just for GP.
     
  4. Blazer_Boy

    Blazer_Boy 1/2 ton status

    Joined:
    Dec 16, 2000
    Posts:
    1,669
    Likes Received:
    0
    Location:
    Sioux City, IA, USA
    Oh, sounds like you screwed up something big. If it were a modulator or governor problem then your shifting would be goofy, but it would maintain some form of forward momentum. Those units are responsible for regulating the pressure in the valve body and tell the tranny when to shift. I've only had the in the valve body assembly apart before so I can't comment to much on the internal workings. Sounds like you f*ed up the second gear clutch and it is falling out of gear when it makes to there. Can you gun the crap outta thing to hold in first gear for a while to see if you could get it up to third gear speed and see if it will take third.
     
  5. Confederate9

    Confederate9 1/2 ton status

    Joined:
    May 29, 2000
    Posts:
    1,686
    Likes Received:
    0
    Location:
    Greensboro NC
    thaqt happened to me this time last year
    i went to school... no problem w/ the tranny
    then on the ride home.. i have nothing but 1st gear.... very imbarassing when driving along a busy road at 20mph and sounding like a nascar.... but anyways
    then i went home and went to back in the drivway and it wouldnt then i finally got it in, but then the next day it would shift into 2nd gear, but would rev up b4 that then it would only get 1st gear again...i went had it looked at.... i jsut went ahead and had it totally rebuilt and it worked perfectly.
    no problems now
    so i thought id let cha know the same thing happened to me and what i did.
     

Share This Page