Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Trans Problem?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Nate87k5, Jun 9, 2003.

  1. Nate87k5

    Nate87k5 Registered Member

    Joined:
    Feb 17, 2000
    Posts:
    77
    Likes Received:
    0
    Location:
    Phoenix, AZ
    Just had my 700r rebuilt about 800 miles ago. I mostly drive in drive and hardly ever in OD. The other day I put the truck in OD to get on the freeway and the truck started surging around 45-60 miles an hour. Mostly when giving the truck gas. I switched it back to Drive and was back to normal... no surging. Truck runs fine other wise and didn't have this problem until I had the trans rebuilt. Any ideas on what may be going on? Thanks.
     
  2. bigblock44k5

    bigblock44k5 1/2 ton status

    Joined:
    Jun 8, 2003
    Posts:
    396
    Likes Received:
    0
    Location:
    Hurlburt Field, FL
    Is the TV Cable hooked up and adjusted properly?
     
  3. BobK

    BobK 1/2 ton status

    Joined:
    Oct 5, 2000
    Posts:
    1,604
    Likes Received:
    0
    Location:
    Petrolia,Ontario,Canada but working in Port Huron,
    Sounds like the tourque converter is locking and unlocking.The rpm sould flucuate a few hundred rpm while it's doing this.
    The T/C will disengage when vacume is low.So say your going up a hill in O/D and the rpm drop a little too much, the T/C will unlock,raising the rpm.
    Sound like it the T/C is "searching".Like aready stated,make sure the T.V. cable is adjusted properly.
     

Share This Page