Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

trans problems with Turbo350

Discussion in 'The Garage' started by cojnit, Mar 24, 2003.

  1. cojnit

    cojnit 1/2 ton status

    Joined:
    Jul 23, 2002
    Posts:
    178
    Likes Received:
    0
    Location:
    Hawthone, CA
    Having problems with my 350 trans. It wont shift into 3rd. It will shift sometimes, if I mess with the shifter and move it from second to third. I am a not so mechanically inclined wheeler. I did manage to change the transmission filter in hopes that this may be the problem. No Help. also checked the vaccum line, it also looks okay.

    Any thoughts??
     
  2. Ryan B.

    Ryan B. 3/4 ton status GMOTM Winner

    Joined:
    Jul 18, 2001
    Posts:
    5,693
    Likes Received:
    0
    Location:
    CA
    [ QUOTE ]
    It wont shift into 3rd. It will shift sometimes, if I mess with the shifter and move it from second to third.

    [/ QUOTE ]
    Sounds like a linkage problem.
    My friend was having a similar problem in his 90 K5, that was just the shifting linkage on the tranny needed to be adjusted just a little.
    I like changing to a cable and floor shifter instead of rod type linkage and the column shifter. /forums/images/graemlins/thumb.gif /forums/images/graemlins/k5.gif
     
  3. cojnit

    cojnit 1/2 ton status

    Joined:
    Jul 23, 2002
    Posts:
    178
    Likes Received:
    0
    Location:
    Hawthone, CA
    correction, the shifter needs to be played with in order to move into second gear as well. you think it could be the same thing? There were no changes made when this happened, just started. Actully now that I think about it I had the front seal for the oil pan go at the same time! Coincidence??
     

Share This Page