Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

trans

Discussion in 'The Garage' started by bigboy, Dec 27, 2005.

  1. bigboy

    bigboy Registered Member

    Joined:
    Nov 8, 2005
    Posts:
    51
    Likes Received:
    0
    Location:
    Lafayette, IN
    hey guys I think my transmission is slipping a little bit but not sure if it is major when it shifts into different gears it seems to no shift hard like I think its sposed to ya know its like kinda slow shifting altho I do not notice the motor reving high during the shift.
     
  2. lamberthkp

    lamberthkp SITFU Premium Member

    Joined:
    Jan 17, 2005
    Posts:
    1,468
    Likes Received:
    16
    Location:
    West TN
    what kind of tranny is it ?how many miles on it ? maybe just the filter needs changed had that problem on a th400 i had .
     
  3. bigboy

    bigboy Registered Member

    Joined:
    Nov 8, 2005
    Posts:
    51
    Likes Received:
    0
    Location:
    Lafayette, IN
    its a 700R4 with 160,000 miles on it.
     
  4. lamberthkp

    lamberthkp SITFU Premium Member

    Joined:
    Jan 17, 2005
    Posts:
    1,468
    Likes Received:
    16
    Location:
    West TN
    have you ever flushed the fluid and changed the filter, on all the 700r4 iv been through that was a problem i had, i never have had much luck with those trannys they always seem to shift crazy. before mine went out last time , it started shifting into the gear then it would bump only in second gear, why dunno? but the shifts felt weak . i am on my 4th 700r4 the last i built myself with the help of a friend who had done it before , its ran fine so far. but if yours it breaks i would say get a th350orth400 but thats your choice to make . GOOD LUCK with the tranny,
     

Share This Page