Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

transmission failure

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by scrappyk5, May 13, 2002.

  1. scrappyk5

    scrappyk5 1/2 ton status

    Joined:
    Mar 17, 2002
    Posts:
    2,099
    Likes Received:
    0
    Location:
    virginia
    well , tranny has been strong untill yesturday morning. i
    went driving down the road and no problems, then i
    did a rolling stop and turned right. i heard some noises
    like bumps and clanks , and then it wouldnt go unless i
    reved it up to around 3000 rpms, then it would start rolling.
    it does it in all gears. 1st,2nd,drive,overdrive,and reverse..
    i checked the fluid and it was red , and about maybe a
    half quart low. i parked it and went and bought a quart , put
    in what was needed and its still doing the same thing.
    i just put this transmission in the vehicle about two weeks ago and havent had a problem. the guy i got it from
    wasnt having a problem either.
    so, what do you guys think?
     
  2. Rebel88

    Rebel88 1/2 ton status

    Joined:
    Sep 7, 2000
    Posts:
    1,855
    Likes Received:
    0
    Location:
    Richmond, VA
    almost sounds like you are missing first gear...maybe second...if it has to wind up to 3 grand to move that isnt good

    Later
     

Share This Page