Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Transmission Problem??

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by **DONOTDELETE**, Jun 27, 2000.

    Hello All, Once my truck heats up the transmission seems like it is hesitating, almost like it does not want to go into overdrive. It feels like a rocking motion. I am really worried, it does not have any getup and go anymore.

    Fluid level is good, but there are bubbles in the fluid.

    Can anyone help...please...thanks

    '84 K5

    Chevy in my blood.
     
  1. JimmyDie6.2

    JimmyDie6.2 1/2 ton status

    Joined:
    Jun 20, 2000
    Posts:
    453
    Likes Received:
    0
    Location:
    Long Island
    If you know of a tranny shop you trust, ask them to diagnos it. You might also want to try and change the filter( the gasket too), and put fresh fluid in it with "trans medic" or some other comparable tranny additive. those pre-87 700s aren't so good, after 87 they beefed them up. I have an 83 700 backing up a diesel. Just had it rebuilt, nothing trick about it, it cost me $1000 even.
     
  2. jimmyjack

    jimmyjack 1/2 ton status

    Joined:
    May 11, 2000
    Posts:
    2,290
    Likes Received:
    0
    Location:
    Tucson Az
    It sounds like your torque convertor isnt locking up correctly. I had the same problem for years. I wouldnt use overdrive unless I was on the freeway. It helped to just ride the brake for a sec or two when it would act up. Also you can have an over ride switch installed from what I've heard. Its not really labor intensive and it works really well. It just prevents the torque convertor from locking out. Good luck

    creepin and crawlin
    Jim
     
  3. SAVAGE1

    SAVAGE1 1/2 ton status

    Joined:
    May 22, 2000
    Posts:
    1,104
    Likes Received:
    0
    Location:
    BAY AREA, CA
    I'm experiencing the same problem on my 85K5. It hesitates to downshift. The tranny is all original. Would you guys recomend a re-build or a whole new tranny all together. Any opinions on the Jet performance trannys?

    BLAZE IT UP!!!
     

Share This Page