Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Truck Not Running That Well

Discussion in 'The Garage' started by 1986chevy_rider, Apr 27, 2007.

  1. 1986chevy_rider

    1986chevy_rider Registered Member

    Joined:
    Nov 8, 2005
    Posts:
    97
    Likes Received:
    0
    Location:
    fallon nv
    My truck has sat for three weeks without being started now the thing doesnt even want to get above 10 miles an hour bogs down bad its not running all that smooth either what could have gone wrong? thanks

    MUD BOGS NEXT WEEKEND AHHH!
     
  2. bluehen

    bluehen 1/2 ton status

    Joined:
    Nov 11, 2004
    Posts:
    215
    Likes Received:
    0
    Location:
    DE
    Could the exhaust be plugged somewhere?
     
  3. 1986chevy_rider

    1986chevy_rider Registered Member

    Joined:
    Nov 8, 2005
    Posts:
    97
    Likes Received:
    0
    Location:
    fallon nv
    Maybe it could be that? Gonna check that this evening. But in the Mean time What else could it be? if its not that. Thanks
     
  4. Chaddy

    Chaddy 1/2 ton status GMOTM Winner

    Joined:
    May 23, 2005
    Posts:
    4,110
    Likes Received:
    2
    Location:
    Salt Lake City,Utah
    Did you check your fuel filter, fuel pressure, plugs, wires......
     
  5. resurrected_jimmy

    resurrected_jimmy 1/2 ton status

    Joined:
    May 23, 2005
    Posts:
    2,241
    Likes Received:
    0
    Location:
    back home in Houston
    when asking questions like this it helps to give engine specs, fuel delivery system and such.... helps guys have a clue with what to suggest
     
  6. 76zimmer

    76zimmer Flyin Rat Premium Member GMOTM Winner

    Joined:
    Nov 14, 2005
    Posts:
    23,031
    Likes Received:
    1,347
    Location:
    Kzoo, Mi
    just what I was going to suggest. I assume its an 86?
     

Share This Page