Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

trucks acting funny.....

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by FatBoyBlazer, Mar 31, 2002.

  1. FatBoyBlazer

    FatBoyBlazer 1/2 ton status

    Joined:
    Feb 22, 2001
    Posts:
    1,508
    Likes Received:
    0
    Location:
    Worcester, MA
    it runs fine went its ben running but on the start up it some times stalls out on me for some reason other than that it runs fine........could it just be a loose distirutor cap???.....and if i can figure it out whats wrong with it the the Mah Dukes is going to make my get rid of it...so i need some help...also i tend to drive fast to xtreamly larger pudles(so water might be getting in places its no suposed to be.....thanks....ryan
     
  2. MudbogAD

    MudbogAD 1/2 ton status

    Joined:
    Jun 29, 2001
    Posts:
    672
    Likes Received:
    0
    Location:
    Las Vegas Nevada, US
    If it is on the startup it could be your choke. It may not be engaging which will make it run bad on startup. My blazer had this problem and I could barely keep it running, especially in the cold.
     
  3. FatBoyBlazer

    FatBoyBlazer 1/2 ton status

    Joined:
    Feb 22, 2001
    Posts:
    1,508
    Likes Received:
    0
    Location:
    Worcester, MA
    its tbi not carb
     
  4. Itali83

    Itali83 1/2 ton status

    Joined:
    Feb 12, 2001
    Posts:
    795
    Likes Received:
    0
    Location:
    Westbrook Maine
    Your cold start injector is bad. It's the sensor right next to the thermostat housing. Mine would start hard, run like a pig until warmed up but after that it ran like a top. So, I would try the cold start injector.
    Ben 87 Jimmy
     
  5. MudbogAD

    MudbogAD 1/2 ton status

    Joined:
    Jun 29, 2001
    Posts:
    672
    Likes Received:
    0
    Location:
    Las Vegas Nevada, US
    Well I didn't know that because it wasn't stated. It was just an assumption.
     

Share This Page