Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Trucks boggin down when i stomp the gas.....

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Silver84k5, Feb 24, 2002.

  1. Silver84k5

    Silver84k5 1/2 ton status

    Joined:
    Feb 7, 2002
    Posts:
    3,769
    Likes Received:
    0
    Location:
    Hillsboro Oregon
    I put the 850 edel q-jet on and its been runnin fine, but its starting to bog down when i stomp the gas, could it be that im not burnin all the fuel thats gettin sent in the cylinders? foul plugs? thx for any help

    If you dont make it the first time, Drink another beer, and press a little harder on the gas
     
  2. 86K5TrailBlazer

    86K5TrailBlazer 1/2 ton status

    Joined:
    Apr 24, 2001
    Posts:
    436
    Likes Received:
    0
    Location:
    Orange,CA
    does it do it off idle or at any rpm? it may be an egr issue with that carb

    <a target="_blank" href=http://www.myk5.com/gallery/>SoCal Big Dawgs</a>
     
  3. Silver84k5

    Silver84k5 1/2 ton status

    Joined:
    Feb 7, 2002
    Posts:
    3,769
    Likes Received:
    0
    Location:
    Hillsboro Oregon
    at any rpm, also it seems like the secondaires arent opening up, i dont know much about carbs so....

    If you dont make it the first time, Drink another beer, and press a little harder on the gas
     
  4. BlueBlazer

    BlueBlazer 1/2 ton status

    Joined:
    Feb 15, 2001
    Posts:
    1,940
    Likes Received:
    0
    Most likely the secondaries are opeining up too fast. With my old Firebird with a Qjet it would bog terribly when I floored it until I discovered this little spring that slowed the opening rate of the secondaries. The bog is probably coming from too much air at one time, not too much fuel or fuel not being burned efficiently.

    82 K5, 6.2L Diesel, sm465, np205, 14 bolt welded, 8 lug 10 bolt lock right, 410 gears, 35" Mud Kings
    SPEAK SOFTLY AND DRIVE A BIG TRUCK
     
  5. 86K5TrailBlazer

    86K5TrailBlazer 1/2 ton status

    Joined:
    Apr 24, 2001
    Posts:
    436
    Likes Received:
    0
    Location:
    Orange,CA
    well see i just put on that carb 1904 and in the direction it mentioned something about a vacuum delay beacuse the erg vacuum source is now lower in the carb than the factory one causing vacuum to be applied whenit souldnt be. Plug the lines and see if goes away.,. Although i still have a bit of a stumble when i floor in on occasion its not as bad and not often. I still got some tunning to do though.

    <a target="_blank" href=http://www.myk5.com/gallery/>SoCal Big Dawgs</a>
     
  6. Silver84k5

    Silver84k5 1/2 ton status

    Joined:
    Feb 7, 2002
    Posts:
    3,769
    Likes Received:
    0
    Location:
    Hillsboro Oregon
    hmm well when i get in my dads truck and stomp the gas, you can hear the 4 barrels kickin in, on mine even when it was running fine, it didnt sound like [censored], i dont have my kick down cable hooked up so that might be it, but it still doesnt seem like they open up, frustrating stuff, thx for the info ill check it out tommorow, then go from there

    If you dont make it the first time, Drink another beer, and press a little harder on the gas
     
  7. Silver84k5

    Silver84k5 1/2 ton status

    Joined:
    Feb 7, 2002
    Posts:
    3,769
    Likes Received:
    0
    Location:
    Hillsboro Oregon
    Dude i suck at tuning this thing, i keep messin with it, but i feel like im getting no where lol, and those instructions look like College material heh, oh well guess itll just take me awhile to get it goin right
    mine was 1910 i think not 1904

    If you dont make it the first time, Drink another beer, and press a little harder on the gas<P ID="edit"><FONT class="small">Edited by Silver84k5 on 02/24/02 09:59 PM.</FONT></P>
     
  8. 84_Chevy_K10

    84_Chevy_K10 Banned

    Joined:
    May 30, 2001
    Posts:
    17,669
    Likes Received:
    0
    Location:
    IL, USA
    Check your ignition first! Most often carb problems are traced to igntion, especially with a new carb!

    Tim
    '84 Chevy K10, lifted, loud, fast, and 3/4 ton axles
     
  9. mudrunner78

    mudrunner78 1/2 ton status

    Joined:
    Sep 7, 2001
    Posts:
    366
    Likes Received:
    0
    Location:
    Rocksprings, TX
    if the carb is bogging and you don't hear the secondarys open, theres a spring on the secondary shaft, thats adjusted by a scew, along with a allen head keeper. My quadrajet used to bog when floored and the secondarys never seemed to open. The reason was this spring which controls tension on the secondaries. mine was to tight thus not allowing the secondaries to open. I backed the screw completely loose then tightened it 1 1/2 turns, then drove around, adjusted until I got it just right. Hope this helps Jesse

    78 K-10 383, TH-350, NP-203, Dana 70 front, GM 14bolt Rear, 4.56 gears(underconstruction) 78 k-5 stock and rusty
     
  10. Silver84k5

    Silver84k5 1/2 ton status

    Joined:
    Feb 7, 2002
    Posts:
    3,769
    Likes Received:
    0
    Location:
    Hillsboro Oregon
    thx ill try that,

    If you dont make it the first time, Drink another beer, and press a little harder on the gas
     

Share This Page