Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

turn signal / brake light problem

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by funkycold, Mar 11, 2004.

  1. funkycold

    funkycold 1/2 ton status

    Joined:
    Apr 22, 2002
    Posts:
    435
    Likes Received:
    0
    Location:
    Orange County, CA
    I tried to search for this before posting, but was not able to find anything.

    Whenever i use my turn signals they work fine right up until i step on the brake pedal. once i step on the brake the brake lights take over and the turn signals stop working. When i taek my foot off of the brake pedal, the turn siganls work again. I have changed all the bulbs, with no luck. I checked the switch and there is power coming out of it since the signals work when i am not on the brake. I did not find a broken wire of anything else. Is there a module that is connected to the turn signal and brake light that may be bad or something else?

    Any suggestions would be great. /forums/images/graemlins/confused.gif
     
  2. Derf00

    Derf00 1/2 ton status

    Joined:
    Jul 25, 2000
    Posts:
    1,683
    Likes Received:
    0
    Location:
    Abilene, TX
    The switch in the steering column is probably bad.
     
  3. POWERMAD

    POWERMAD 1/2 ton status

    Joined:
    Mar 4, 2001
    Posts:
    3,466
    Likes Received:
    0
    Location:
    Oregon
    The turn signal and brake circuit run through the turn signal switch.
    That would be next spot to look into.
     

Share This Page