Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Turn signals work with lights off......won't work with lights on

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by dawson444, Jan 21, 2002.

  1. dawson444

    dawson444 1/2 ton status

    Joined:
    Jul 5, 2000
    Posts:
    1,034
    Likes Received:
    0
    Location:
    Raleigh, NC
    Turn signals work with lights off......won\'t work with lights on

    My turn signals work fine normally. Then when you turn on the lights and the left arrow lights up kind of dim, and neither one of the turn signals will work. Please help! Thanks!

    Dawson
    Raleigh, NC

    88 K5, 6" lift, 36" TSL Radials, 14 Bolt, Rancho 9012s
     
  2. Michael

    Michael 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,576
    Likes Received:
    0
    Location:
    Sherman, Texas
    Re: Turn signals work with lights off......won\'t work with lights on

    Sounds like the parking light circuit is somhow shorted to the signal circuit. Make sure the bulbs are in corrctly and the sockets are nice and clean. Check the side marker ligths also.

    Michael[​IMG]
    <a target="_blank" href=http://www.jmartin.net/parker/goose.htm>www.jmartin.net/parker/goose.htm</a>
     
  3. Michael

    Michael 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,576
    Likes Received:
    0
    Location:
    Sherman, Texas
    Re: Turn signals work with lights off......won\'t work with lights on

    Sounds like the parking light circuit is somhow shorted to the signal circuit. Make sure the bulbs are in corrctly and the sockets are nice and clean. Check the side marker lights also.

    Michael[​IMG]
    <a target="_blank" href=http://www.jmartin.net/parker/goose.htm>www.jmartin.net/parker/goose.htm</a>
     
  4. Grim-Reaper

    Grim-Reaper 3/4 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    7,385
    Likes Received:
    0
    Location:
    Atlanta
    Re: Turn signals work with lights off......won\'t work with lights on

    Check your body grounds. In particulare the ground strap off the passenger side head to the firewall. Why it works with the lights off is it is pulling ground through the lights on the core suport. Once the lights are turned on the route is gone so it quits.

    Women dig dents and flat paint!
    coloradok5.com/gallery/Grim
    75 Jimmy, Dollar
    Grim-Reaper
     
  5. Burbinator

    Burbinator 1/2 ton status

    Joined:
    Sep 14, 2001
    Posts:
    898
    Likes Received:
    0
    Location:
    Tempe, Arizona
    Re: Turn signals work with lights off......won\'t work with lights on

    Make sure that your tail light and grille light park/turn bulbs are dual filaments. I've seen a single filament bulb mistakenly put in and it does the same thing.

    Haze gray and underway...<font color=blue>or blue, in my case.</font color=blue>
    <a target="_blank" href=http://community.webshots.com/album/26246038MbQsYWKcbo>U.S.S. Nimitz II</a>
     
  6. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,982
    Likes Received:
    191
    Location:
    Roy WA
    Re: Turn signals work with lights off......won\'t work with lights on

    you happen to have the wrong (or faulty) bulbs in the parking/marker lights front or rear?

    Dorian
    My tech/links page: <a target="_blank" href=http://www.dorianyeager.com/index2.html>www.dorianyeager.com/index2.html</a>
    Why insist on counting when the ring gear has the tooth counts stamped in?
     

Share This Page