Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

u joints

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 85GMCJimmy, Sep 23, 2000.

  1. 85GMCJimmy

    85GMCJimmy Registered Member

    Joined:
    Feb 21, 2000
    Posts:
    83
    Likes Received:
    0
    Location:
    South Carolina
    My jimmy is using up u joints like they are going out of style for some reason, if i get it fixed it will have been my third set within a year. I have a stock jimmy, with 31's on it, with a 10 bolt rear end..
     
  2. k5king

    k5king 1/2 ton status

    Joined:
    Jul 23, 2000
    Posts:
    571
    Likes Received:
    0
    Location:
    Parkesburg, Pennsylvania
    well either you keep putting them in wrong OR you have a severe driveline angle problem! do you have lift,or any kinda' drop motor and tranny mounts?

    DRIVE IT LIKE YOU STOLE IT
     
  3. '73 K5

    '73 K5 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,763
    Likes Received:
    0
    Location:
    Kansas
    Maybe the driveshaft is out of balance.

    '73 K5
    Chevy good...Ford bad
     
  4. DBLAZER

    DBLAZER 1/2 ton status

    Joined:
    Apr 2, 2000
    Posts:
    1,716
    Likes Received:
    0
    Location:
    Haslet, Tx
  5. TX Mudder

    TX Mudder 1/2 ton status

    Joined:
    Jul 10, 2000
    Posts:
    2,514
    Likes Received:
    0
    Location:
    Houston
    With 31's, you can't have too much lift. Stock or maybe 2". How bad can the driveline angles be?
    I wonder what kind of condition the driveshafts are in? IF they are way out of balance or the slipshaft is loose, it wears the ujoints out quickly.
    -- Mike
     
  6. Blazer79

    Blazer79 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,816
    Likes Received:
    0
    Location:
    Guatemala, Central America
    What brand are you using? Try getting Spicer greaseables and grease them often. Maybe that will help.

    <font color=blue>//////
    http://blazer79.coloradok5.com
    </font color=blue>[​IMG]
     
  7. drivelineman

    drivelineman 1/2 ton status

    Joined:
    Aug 23, 2000
    Posts:
    707
    Likes Received:
    0
    are you pre greasing? and you might have a dad yoke - loose holes etc- jess
     
  8. 85GMCJimmy

    85GMCJimmy Registered Member

    Joined:
    Feb 21, 2000
    Posts:
    83
    Likes Received:
    0
    Location:
    South Carolina
    on my jimmy i have no lift on mine, do you think when they replaced them one of the drive line angles got out of wack any
     
  9. drivelineman

    drivelineman 1/2 ton status

    Joined:
    Aug 23, 2000
    Posts:
    707
    Likes Received:
    0
    no i don't. maybe a spinning cap in your shaft though-
     
  10. DMK

    DMK 1/2 ton status

    Joined:
    Feb 20, 2000
    Posts:
    757
    Likes Received:
    0
    Location:
    CINCINNATI, OH
    Maybe tightening straps too much.
     
  11. ftn96

    ftn96 1/2 ton status

    Joined:
    Sep 26, 2000
    Posts:
    3,238
    Likes Received:
    0
    Location:
    Nashville Tn
    Is she viberating pretty good at or around 55?? Sounds like from what you stated about no lift and 31's, no angle issues apply. I would just get and new drivshaft and new u-joints.
     

Share This Page