Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

UPDATE I messed up, need heeeelp

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by jimmyjack, May 8, 2001.

  1. jimmyjack

    jimmyjack 1/2 ton status

    Joined:
    May 11, 2000
    Posts:
    2,290
    Likes Received:
    0
    Location:
    Tucson Az
    I was cleaning my engine looking for an oil leak. Wasn't paying attention and the hot wire for the HEI dist popped out and was resting on the intake. Went to start it and all I got was a click and all went dead. Looked around, checked fuses. Everything thing seemed good. Did it again, all went dead and a massive puff of smoke rose from the firewall. Needless to say I fried some wires. Didn't burn them down but definately heated them up. Found the HEI lead, plugged it in. Motor cranked, but no spark. Replaced the module. Wouldn't start, no spark. But as soon as my wife let the key return to the on position, it fired. Checked it again. Turned the key, motor turns, no spark, she lets the key return and it cranks. What gives. Is my ignition switch toast? Everything else is good. Dashlights, headlights turn signals brakelights. Didn't burn any fuses or other wires, just the big red one and a smaller pink one spliced in with big red one going to the dist. What gives. Are my Hawaiian seat covers cursing my blazer like that Idol did to Greg on the Brady Bunch? Please lemme know what you think!!!!!!!!! Send me an e mail or PM with your number and I'll call you.

    "My blazer may be slow, but it goes faster at higher speeds"

    Jim<P ID="edit"><FONT SIZE=-1>Edited by jimmyjack on 05/09/01 04:25 PM (server time).</FONT></P>
     
  2. Pugsley

    Pugsley 1/2 ton status

    Joined:
    Jan 16, 2001
    Posts:
    3,556
    Likes Received:
    0
    Location:
    Tucson, Arizona
    Re: I messed up, need heeeelp

    I've got my money on a fusible link - I just emailed with a little more indepth description.

    [​IMG]
     
  3. jimmyjack

    jimmyjack 1/2 ton status

    Joined:
    May 11, 2000
    Posts:
    2,290
    Likes Received:
    0
    Location:
    Tucson Az
    Re: I messed up, need heeeelp

    I guess I didn't type what I was saying to myself. The engine WILL START but only AFTER the key is released. I was looking for spark as the engine was turning, I told my wife to stop cranking and as soon as she did the motor fried up

    "My blazer may be slow, but it goes faster at higher speeds"

    Jim
     
  4. Pugsley

    Pugsley 1/2 ton status

    Joined:
    Jan 16, 2001
    Posts:
    3,556
    Likes Received:
    0
    Location:
    Tucson, Arizona
    Re: I messed up, need heeeelp

    Hmmmm.....Ok, my suggestion would be beer. Or possibly the ignition and starter wires somehow got crossed.

    [​IMG]
     
  5. JunkYardCrawler

    JunkYardCrawler 1/2 ton status

    Joined:
    Sep 9, 2000
    Posts:
    575
    Likes Received:
    0
    Location:
    Tucson, AZ
    Re: I messed up, need heeeelp

    man u did mess it up. i don't hink its the seat covers though. i think you should let your boy fix it. you would be suprised at what us kids can do. =)
     
  6. michaelm

    michaelm 1/2 ton status

    Joined:
    Feb 2, 2001
    Posts:
    872
    Likes Received:
    0
    Re: I messed up, need heeeelp

    my vote is for ign switch fried when you shorted it.
    update when you find it.
     
  7. jimmyjack

    jimmyjack 1/2 ton status

    Joined:
    May 11, 2000
    Posts:
    2,290
    Likes Received:
    0
    Location:
    Tucson Az
    Here's the deal. I drove it to work today. Same thing. I cranked the motor and as asoon as I released the key it started. On the way home I made a few stops, same thing. Now get this, I stopped at the parts store. Bought some wire, A fusible link, (you were dead on Pugsley) some connectors and such. Get in and it starts up normal. Just like it did 5 minutes before I fried the wires. What the hell is going on!!!!!! Going to replace all the wires and stuff just cos I bought them. Its gotta be the seat covers!

    "My blazer may be slow, but it goes faster at higher speeds"

    Jim
     
  8. mudhog

    mudhog THEGAME Staff Member Super Moderator

    Joined:
    Nov 6, 2000
    Posts:
    17,899
    Likes Received:
    2
    Location:
    portland oregon
    i think its the seat covers also[​IMG]

    77blazer see it at<A target="_blank" HREF=http://community.webshots.com/user/ssmith6333>http://community.webshots.com/user/ssmith6333</A>[​IMG]
     

Share This Page