Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

** UPDATED ** won't start -- battery problem?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 77Jimmy, Nov 15, 2002.

  1. 77Jimmy

    77Jimmy 1/2 ton status

    Joined:
    Sep 3, 2002
    Posts:
    661
    Likes Received:
    0
    Location:
    Atlanta, GA
    ** UPDATED ** won\'t start -- battery problem?

    Problem solved. Took battery to Autozone, tested it. Battery OK, just low. They charged it, brought it home and it cranked right up. Thanks for the help! /forums/images/graemlins/grin.gif


    Been a couple of weeks since I last started up and ran my truck. Went out to start is up yesterday and nothing. No sounds, no nothing. Headlights wouldn't work, nothing. I'm guessing it's a dead battery??? /forums/images/graemlins/confused.gif
     
  2. sosamantx

    sosamantx 1/2 ton status

    Joined:
    Aug 14, 2000
    Posts:
    393
    Likes Received:
    0
    Location:
    somewhere in Texas
    Re: won\'t start -- battery problem?

    i'd probably say yeh it's a battery problem, since the lights don't come on. you can check the voltage with a meter, or just pull it out and take it to autozone or somewhere and have them charge it (if needed), and test it, it's free normally. are you sure that you didn't leave anything on? it should start within a few weeks, but maybe not a few months? the battery might drain some?
     
  3. 77Jimmy

    77Jimmy 1/2 ton status

    Joined:
    Sep 3, 2002
    Posts:
    661
    Likes Received:
    0
    Location:
    Atlanta, GA
    Re: won\'t start -- battery problem?

    Nope, didn't leave anything on. I thought it was strange that it would die (assuming it's the battery) after a couple of weeks. I filled it up w/ distilled water a few months back. Oh well, I'll pull it out and take it to Autozone. Thanks.
     
  4. TopOff

    TopOff 1/2 ton status

    Joined:
    Jan 16, 2002
    Posts:
    1,760
    Likes Received:
    0
    Location:
    Folsom, ca
    Re: won\'t start -- battery problem?

    Check your connections first...

    Good luck.
     
  5. chevyracing

    chevyracing 1/2 ton status

    Joined:
    Sep 8, 2001
    Posts:
    2,589
    Likes Received:
    0
    Location:
    Colorado
    Re: won\'t start -- battery problem?

    Electrical problems are [​IMG], I hate them, I hate them, I hate them.

    John
     
  6. Tweetysuarus

    Tweetysuarus 1/2 ton status

    Joined:
    May 25, 2002
    Posts:
    2,294
    Likes Received:
    0
    Location:
    Lynnhood,WA
    Re: won\'t start -- battery problem?

    I had wired the Electric Choke to constant hot+ instaed of Ignition Hot+ this lead me to have dead battery! Although alittle more info on your rigs Bio would be nice. Shorts can drian the battery.
    Bill
     
  7. 77Jimmy

    77Jimmy 1/2 ton status

    Joined:
    Sep 3, 2002
    Posts:
    661
    Likes Received:
    0
    Location:
    Atlanta, GA
    Re: ** UPDATED ** won\'t start -- battery problem?

    I meant to take this ttt when I edited it but I guess that's not the way to do it.

    Just an fyi for the folks that had some suggestions on my battery problem. Thanks!
     

Share This Page