Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

urgent pontiac question

Discussion in 'The Garage' started by obijuan, Nov 13, 2006.

  1. obijuan

    obijuan 1/2 ton status GMOTM Winner

    Joined:
    May 18, 2006
    Posts:
    4,009
    Likes Received:
    0
    Location:
    San Antonio TX
    i would post this in the other rides section but no posts in two days there so, its a 96 pontiac grand am 2.4. does the serp belt have anything to do with time? i have replaced the coil housing? plugs and wire type things last month and it ran great but today, its not even firing and when it tries to crank over its squeels from the belt and its pretty loose. arent these supposed to be rather taut? i have a feeling it jumped time but i have no real knowlegde about this car. any help would be greatly appreciated!! thanks in advance
     
  2. BROKEN-ONE

    BROKEN-ONE Registered Member

    Joined:
    Sep 15, 2005
    Posts:
    78
    Likes Received:
    0
    Location:
    kansas
    no the serp belt does not have anything to do with the timing . how old is the belt ? does the tensioner look broken , like the end is broke ? or the pulley worn out ? the no spark issue may be a couple of things this car still has a module ? might check that . the timing grears are metal , with this being a 2.4l it should be a dual over head cam engine , the only thing that usally goes bad here is the adjuster shoes and tensioner , these are behind the big flat black cover , if you need to look in there it is a severe pain to do . hope this helps .
     
  3. obijuan

    obijuan 1/2 ton status GMOTM Winner

    Joined:
    May 18, 2006
    Posts:
    4,009
    Likes Received:
    0
    Location:
    San Antonio TX
    damn... damn damn damn. belt is in good shape, how would a worn pulley look? how can i find a list of codes for this car, the check engine light is on. thanks for the help, i think its time to sell this car. lol the module is the deal under the white housing i replaced huh? that the wires plug into? ill check that before the flat cover. thanks again
     
  4. BROKEN-ONE

    BROKEN-ONE Registered Member

    Joined:
    Sep 15, 2005
    Posts:
    78
    Likes Received:
    0
    Location:
    kansas
    Aldl

    to check the codes you can jump the ports to see what codes flash , and yes the piece under the the white tower is the module . it is going to cost a pretty penny too . the pulley will look like you can the inside struture is about to or is coming out . if you have a questions about this , replace it they normally cheap and easy to do . just because it is broke dont give up on it . those engines rock , plenty of power for hwy driving , and surprising the guy next to you . i get with my wifes buick skylark "same engine " 28mpg .
     
  5. pauly383

    pauly383 Daddy383 Staff Member Moderator

    Joined:
    Jul 22, 2001
    Posts:
    16,217
    Likes Received:
    1
    Location:
    Mesa , Arizona USA
    If it was built after 1-1-1996 , it has OBDII and a different port from the regular aldl your thinking of .
     
  6. BROKEN-ONE

    BROKEN-ONE Registered Member

    Joined:
    Sep 15, 2005
    Posts:
    78
    Likes Received:
    0
    Location:
    kansas
    if you can not flash it , when you can get it running go up to the auto zone near you they can run the codes . and yes i know it's Autozone , but not all of them a are bad . if you dont want to try that try a good local shop ask around , some one you know has had a good experance with 1 around you . hope this helps .
     
  7. obijuan

    obijuan 1/2 ton status GMOTM Winner

    Joined:
    May 18, 2006
    Posts:
    4,009
    Likes Received:
    0
    Location:
    San Antonio TX
    it was made 9-95. is that OBDI im assuming? does my 85 k5 have one of these ports? i think i can find somebody with a reader that will let me use it. thanks for your help.
     

Share This Page