Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

? v6 vortec engine

Discussion in 'The Garage' started by chevystepside, Apr 28, 2004.

  1. chevystepside

    chevystepside 1/2 ton status

    Joined:
    Sep 23, 2002
    Posts:
    147
    Likes Received:
    0
    Location:
    leadville colo
    ive got a buddy with a 1994 s10 jimmy with a v6 vortec. it is making a grinding noise at the front of the engine. i thought that it was the waterpump so to verify i removed the serp belt. but the noise did not go away. has anyone had or heard of a problem like this? im going to remove all the accecerys this weekend and remove the timing cover cause it sounds like it is at the front of the engine. any help would be greatly apprecated /forums/images/graemlins/1zhelp.gif
     
  2. chevystepside

    chevystepside 1/2 ton status

    Joined:
    Sep 23, 2002
    Posts:
    147
    Likes Received:
    0
    Location:
    leadville colo
    ttt /forums/images/graemlins/1zhelp.gif
     
  3. sled_dog

    sled_dog 1 ton status

    Joined:
    Sep 3, 2002
    Posts:
    16,870
    Likes Received:
    0
    Location:
    Austin, TX
    check in the timing cover and all. I think those motors have a balance shaft, maybe something got screwed up in it.
     
  4. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    I would just make sure that nothing up front is loose. My truck motor made a "knocking" sound that seemed to be getting louder and louder so I eventually pulled the motor.

    From what I could tell after I pulled it, the crank pulley somehow had loosened up, and I *think* the noise was it, as it walked around on the loose bolts as the engine turned.
     

Share This Page