Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Vacuum leak?????????

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by PGL4VT, May 6, 2002.

  1. PGL4VT

    PGL4VT Registered Member

    Joined:
    Feb 10, 2002
    Posts:
    71
    Likes Received:
    0
    Location:
    Roanoke, Virginia
    91 K-5. My cruise control won't hold on hills anymore and my climate controls don't work properly anymore. I put it on defrost and air blows from the dash vents and floor. I put it on floor and it blows from all places. Also, the truck idles fine but when I stop at a light and it's in drive, the idle becomes really rough. Vacuum leak? Ideas? Anyone had this happen? Thanks.

    91 K-5
    72 K-5
     
  2. NoSmog73

    NoSmog73 1/2 ton status

    Joined:
    Sep 28, 2001
    Posts:
    2,348
    Likes Received:
    0
    Location:
    lodi,ca
    I don't have the cruise but I would check (on mine at least) there is a vaccume port screwed into the back of the intake right behind the carb in front of the dis. I would check all the main vaccume lines that go to the components that are messing up ( they might even tie into the same vaccume port)...mike
     
  3. jimmyjack

    jimmyjack 1/2 ton status

    Joined:
    May 11, 2000
    Posts:
    2,290
    Likes Received:
    0
    Location:
    Tucson Az
    It sure sounds like a vacuum leak to me. Espescially when you mention the flappers under the dash not working right. Get a can of carb cleaner and start spraying around. Be careful around the distributor, I burned my eyebrows off once!!
     
  4. mlb79

    mlb79 Registered Member

    Joined:
    May 24, 2001
    Posts:
    40
    Likes Received:
    0
    Location:
    evansville, IN
    I'm not sure about the 91, but on my 79 there is a small piece of vacuum hose on top of the blend box. The hose is kinda tough to get to unless the blend box is out of the truck. Mine was dry rotted and leaking badly, it is connected to a diaphram. The 91 may be very different, at least now you know there is one hiding.
     

Share This Page