Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Vacuum line routing....need help

Discussion in 'The Garage' started by readymix, Feb 8, 2007.

  1. readymix

    readymix 3/4 ton status

    Joined:
    May 30, 2004
    Posts:
    6,706
    Likes Received:
    26
    Location:
    Murrieta, California
    My buddy has a 85 K10 with a 305 and he is trying to sort out the cluster fock that the P.O. did to it. We have looked online and found a few diagrams for the vacuum hoses but they are not quite right.

    Could someone please take a pic of thier engine bay showing the vacuum hoses, connections and routing so we could get this done.
     
  2. dirtynails

    dirtynails Registered Member

    Joined:
    Aug 28, 2005
    Posts:
    96
    Likes Received:
    0
    Location:
    Gosport, Indiana
    The Chilton's book has a couple dozen pages of vacuum diagrams, you can probably find something there.
     
  3. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,982
    Likes Received:
    191
    Location:
    Roy WA
    Don't assume the '83 305 label is correct, but you might get some use out of it, sorry I don't have exacts. I really need to take the digital camera to the wrecking yard with me. :(

    Does LMC sell these now?
     
  4. readymix

    readymix 3/4 ton status

    Joined:
    May 30, 2004
    Posts:
    6,706
    Likes Received:
    26
    Location:
    Murrieta, California
    Yeah he has the sticker on the core support but it looks like the PO removed or broke some of the parts that should be on the truck.

    That is why I would like a few pictures.
     
  5. 1983Blazerkid

    1983Blazerkid Registered Member

    Joined:
    Nov 12, 2005
    Posts:
    98
    Likes Received:
    0
    Location:
    brownsburg, in
    i know that feeling half of the stuff on my truck the PO just hacked off unbolted whatever. it amazes me it still runs. :doah:
     

Share This Page