Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Valve seals

Discussion in '1982-Present GM Diesel' started by Tybee, Jul 23, 2002.

  1. Tybee

    Tybee 1/2 ton status

    Joined:
    Mar 25, 2001
    Posts:
    1,565
    Likes Received:
    0
    Location:
    Centennial, CO
    Anybody ever replace them? How hard to replace?
     
  2. calcide

    calcide 1/2 ton status

    Joined:
    Dec 21, 2001
    Posts:
    283
    Likes Received:
    0
    Is this for your truck? Don't you have new heads?
     
  3. Tybee

    Tybee 1/2 ton status

    Joined:
    Mar 25, 2001
    Posts:
    1,565
    Likes Received:
    0
    Location:
    Centennial, CO
    Yes, and the heads are almost a year old. Its the only thing I can think of that could be the cause of my oil consumtion. Im not leaking any and im going through a quart every 25 to 35 miles! /forums/images/icons/shocked.gif
     
  4. arveetek

    arveetek 1/2 ton status

    Joined:
    Mar 1, 2002
    Posts:
    722
    Likes Received:
    0
    Location:
    Granby, MIssouri, USA
    Holy batman! A quart in 25 to 30 miles? You'd better be doing a compression check. I don't think valve stem seals could be your problem. More likely bad or broken rings.

    Casey
     
  5. Tybee

    Tybee 1/2 ton status

    Joined:
    Mar 25, 2001
    Posts:
    1,565
    Likes Received:
    0
    Location:
    Centennial, CO
    when I bought the truck almost 2 years ago it didnt go through oil at all. I replaced the heads and had a valve cover leak, I thought all the oil was leaking from there. After replacing the valve cover and gasket there is now no leak. And I figured the rings wouldnt go bad that fast. I also never noticed a power difference, just a slight one when I put the 35s on. Any other suggestions? Thanks, Troy
     

Share This Page