Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

valve train noise?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by ZK5, Aug 8, 2004.

  1. ZK5

    ZK5 1/2 ton status

    Joined:
    Dec 16, 2001
    Posts:
    100
    Likes Received:
    0
    Location:
    Meriden, CT
    My engine developed a ticking noise similar to loose rock arms only not quite as loud at RPMs of 3000 and higher. Basicly, at 3000 and above it sound like the whole valvet train went loose at the same time or it's pingin realy loudly. I've adjusted the valve-train countless times and they are new heads. I thought it might have been worn valve guides at first so I had them rebuilt and opened up a bit too. The motor is fresh too. Could this be a timing issue? or too cold of a spark? I am thinking of trying hotter plugs. Has anyone here ever had a similar problem?
     
  2. backcountry

    backcountry 1/2 ton status

    Joined:
    May 27, 2004
    Posts:
    916
    Likes Received:
    0
    When you changed your heads, what compression did you end up with? If your compression is too high, you will have problems with low octain fuel. Try bumping up your octain and see if it helps. Also, you are going to need to set your initial timing and total timing. /forums/images/graemlins/peace.gif
     
  3. big83chevy4x4

    big83chevy4x4 3/4 ton status

    Joined:
    Mar 22, 2002
    Posts:
    6,587
    Likes Received:
    0
    Location:
    Sheridan, Michigan
    are the lifters good?

    i built a friends motor, i told him to buy the comp lifters, but he insisted on getting the federal mogal lifters because their cheaper. we put them in and about 500 miles or so, the motor created a ticking sound after warmup. we readjusted the rockers 3-4 times and still had it, replaced the stock arms with cranes aluminum full roller rockers and comp push rods and it still did it. finely we desided that the lifters we not staying pumped up. we put a highrise intake on it and comp lifters in it and all was perfect, no noise any more.

    his only did it when it was warm, idle through about 4000 then you couldn't hear it over the exhaust.

    just a guess /forums/images/graemlins/dunno.gif
     

Share This Page