Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Vibration and Locking

Discussion in 'The Garage' started by grindkings, Jan 2, 2005.

  1. grindkings

    grindkings 1/2 ton status

    Joined:
    Dec 24, 2004
    Posts:
    127
    Likes Received:
    0
    Location:
    Marshall, Missouri
    I just replaced the front u-joint on the axle. Went for a test drive and still had lots of vibration in the front end. Then as i began braking, one of the rear tires locked up, then unlock. Not sure what this is caused by, maybe bad diff or brakes or anything. need so help boys.
     
  2. 85mudblazin

    85mudblazin 1/2 ton status

    Joined:
    Mar 26, 2004
    Posts:
    3,951
    Likes Received:
    0
    Location:
    Austin,TX
    did you replace the u-joint in the axle shaft or the front driveshaft??
     
  3. grindkings

    grindkings 1/2 ton status

    Joined:
    Dec 24, 2004
    Posts:
    127
    Likes Received:
    0
    Location:
    Marshall, Missouri
    The one that connects to the front diff.
     
  4. Leadfoot

    Leadfoot 1/2 ton status Premium Member

    Joined:
    Nov 28, 2000
    Posts:
    3,112
    Likes Received:
    1
    Location:
    Western Massachusetts
    The vibration could be alot of things in the front end. Was it there before the u-joint replacement?

    As for the rear wheel locking up, it most likely is a leaking wheel cylinder or if have a 14 bolt, it could be a bad hub/axle seal.
     
  5. grindkings

    grindkings 1/2 ton status

    Joined:
    Dec 24, 2004
    Posts:
    127
    Likes Received:
    0
    Location:
    Marshall, Missouri
    it was doing it befor i replaced the u-joint, thats why i replaced it.
     
  6. tunedportk5

    tunedportk5 1/2 ton status

    Joined:
    Jul 13, 2004
    Posts:
    371
    Likes Received:
    0
    Location:
    Union City, CA
    was the truck sitting for a while cause that can cause some rust build up on the brake drums and make it lock up it usaully goes away with in a couple miles
     
  7. grindkings

    grindkings 1/2 ton status

    Joined:
    Dec 24, 2004
    Posts:
    127
    Likes Received:
    0
    Location:
    Marshall, Missouri
    No it happend when i went mudding.
     
  8. tunedportk5

    tunedportk5 1/2 ton status

    Joined:
    Jul 13, 2004
    Posts:
    371
    Likes Received:
    0
    Location:
    Union City, CA
    could there be mud throwing things of balance
     
  9. 85mudblazin

    85mudblazin 1/2 ton status

    Joined:
    Mar 26, 2004
    Posts:
    3,951
    Likes Received:
    0
    Location:
    Austin,TX
    Do you still have the rear 10b?? if so then just take the drum off and I would bet there is mud caked in the drum just clean it out with some brake clean and all should be fixed.
    As for the vibration is it coming from the front??
     
  10. grindkings

    grindkings 1/2 ton status

    Joined:
    Dec 24, 2004
    Posts:
    127
    Likes Received:
    0
    Location:
    Marshall, Missouri
    It feels like the front. But when i drove it, i felt a hard bang and then the tires locked up when i started braking. then unlock
     
  11. 85mudblazin

    85mudblazin 1/2 ton status

    Joined:
    Mar 26, 2004
    Posts:
    3,951
    Likes Received:
    0
    Location:
    Austin,TX
    If the vibration is in the front it could be a number of things but did the vibration start after you went mudding??
     
  12. grindkings

    grindkings 1/2 ton status

    Joined:
    Dec 24, 2004
    Posts:
    127
    Likes Received:
    0
    Location:
    Marshall, Missouri
    correct after i went. Thats why i figured i blew a u-joint.
     
  13. 85mudblazin

    85mudblazin 1/2 ton status

    Joined:
    Mar 26, 2004
    Posts:
    3,951
    Likes Received:
    0
    Location:
    Austin,TX
    are you sure it is out of 4wd?? maybe the shaft is out of balance and the vibration is in the shaft and it is still in 4wd.
     
  14. grindkings

    grindkings 1/2 ton status

    Joined:
    Dec 24, 2004
    Posts:
    127
    Likes Received:
    0
    Location:
    Marshall, Missouri
    yea, I've been driving it for almost two days(well not actually driving because but i had to drive it about 12 miles home.)
     
  15. 85mudblazin

    85mudblazin 1/2 ton status

    Joined:
    Mar 26, 2004
    Posts:
    3,951
    Likes Received:
    0
    Location:
    Austin,TX
    well then maybe you have a wheel bearing going south, just check everyhting for looseness or excessive wear.
     
  16. grindkings

    grindkings 1/2 ton status

    Joined:
    Dec 24, 2004
    Posts:
    127
    Likes Received:
    0
    Location:
    Marshall, Missouri
    the hole rear drvier side drum was busted. I could just pull the outside of it off and the internals where all rusted. How do i reapair this brake?
     

Share This Page