Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Water Temp Question

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by CrazeeBush, Apr 20, 2000.

  1. CrazeeBush

    CrazeeBush 1/2 ton status

    Joined:
    Apr 17, 2000
    Posts:
    464
    Likes Received:
    0
    Location:
    Middle Tennessee
    Okay here's the deal, my truck was running like 230 degrees and I replaced the Water pump and the thermostat. It runs cooler, but I still don't think it's right. I put in a 195 thermostat and my truck runs 210-220 degrees. It runs hottest while I'm driving, but when I pull up to a stop light it drops to 210. Anybody have any ideas for me? I'm really stumped. Could it be timing? Maybe a clogged radiator, or a bad fan? I'd really appreciate some input on this one.

    Thanks in advance,
    Josh
     
  2. Corey-88K5

    Corey-88K5 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    720
    Likes Received:
    0
    Location:
    Home: Michigan, Stationed: Hill AFB (Home of Moab.
  3. CrazeeBush

    CrazeeBush 1/2 ton status

    Joined:
    Apr 17, 2000
    Posts:
    464
    Likes Received:
    0
    Location:
    Middle Tennessee
    Yah, stock fan shroud....
     
  4. hpfire7227

    hpfire7227 Registered Member

    Joined:
    Mar 14, 2000
    Posts:
    75
    Likes Received:
    0
    Location:
    Holland Patent, NY
    back to basics...check your coolant level...hey, you never know.

    10 BOLTS O' FUN
     
  5. 88Jimmy

    88Jimmy 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    100
    Likes Received:
    0
    Location:
    Las vegas, NV
    what type of gauge are you using stock??
    I went out and pick up a scanner from Schucks for 160 bucks
    it reads the computer and my stock gauge lies like a big dog!! I watch my gauge goto 210 then down midway to 100*
    and the scanner shows 198 to 204. I watch the gauge drop coming off the freeway but the scanner show the temp is going up.
    The scanner is AutoXray EZlink

    350 Vortec TPI D60 14Bolt 4"lift 35 BFG A/T
     
  6. coopertwpk

    coopertwpk 1/2 ton status

    Joined:
    Mar 18, 2000
    Posts:
    478
    Likes Received:
    0
    Location:
    Spring Valley Lake Ca.
    Ok you have A TBI motor with a 195 therm that means your motor will run at 210 which is bad on 700r4 trans and seems to high but thats life ,what you need is a 185 therm it will drop the temp and you will still pass smog fine,the reason for the high temp is it gets better smog levels at higher temps so it runs high.I have a 91s10 and my 88k5 both did this now they run about 190 maybe.
     
  7. CrazeeBush

    CrazeeBush 1/2 ton status

    Joined:
    Apr 17, 2000
    Posts:
    464
    Likes Received:
    0
    Location:
    Middle Tennessee
    OKay, Here's some info on my truck maybe that will help. Yes I have a stock guage, and I'm not sure that it's right so I'm gonna check it against another guage. It's an '83 K5 with stock Q-Jet carb. 700r4 trans if that's anything to ya. Anything else that I might check?
     
  8. NYC K5

    NYC K5 1/2 ton status

    Joined:
    Apr 3, 2000
    Posts:
    185
    Likes Received:
    0
    Location:
    Staten Island NY/da bronx
    ive was having the same problem. my gague was reading 245 at 75mph, turns out the gage is off by 30 degrees. now im running hotter that its warming up, i did a water pump last year, tommorow im doing a radiator it was only $179 at pep boys which is cheap insurance. the dam things just get old and cloged.
     
  9. Impex

    Impex 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    469
    Likes Received:
    0
    Location:
    Chandler, AZ
    Yeah i just upgraded my radiator to an 4core. It will be worth it when summer hits..
     
  10. NYC K5

    NYC K5 1/2 ton status

    Joined:
    Apr 3, 2000
    Posts:
    185
    Likes Received:
    0
    Location:
    Staten Island NY/da bronx
    i did my radiator this morning and my temp droped 30 at highway speed, the old one was so corroded that when you touched the fins most of them pushed right out.
     
  11. CrazeeBush

    CrazeeBush 1/2 ton status

    Joined:
    Apr 17, 2000
    Posts:
    464
    Likes Received:
    0
    Location:
    Middle Tennessee
    Thanks, looks like a new radiator is gonna go on my truck. :)

    (Unless my guage is bad) Anyone have any probs with bad fact guages?
     
  12. jarheadk5

    jarheadk5 1/2 ton status

    Joined:
    Mar 6, 2000
    Posts:
    4,389
    Likes Received:
    0
    Location:
    PA
    I think all of the factory gauges suck. My oil pressure goes up to 60+ PSI sometimes, then drops to 10 or so. The temp will run up to 240 deg. and stay there occasionally, but I'll tap the gauge face or hit a bump and it 'll drop to 190 or so. I'm just gonna ditch the old ones and go with Autometers.

    [​IMG] Semper Maintenance!
    [​IMG] So many ideas, so little money...
     
  13. Blazerbob

    Blazerbob 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    214
    Likes Received:
    0
    Location:
    Western NY
    I put a Hi-flow water pump on my 83 and a 160 thermostat and now she runs around 165-170. It used to run around 210-220 and I didn't like the trans getting that warm

    <font color=blue>Blazerbob</font color=blue>[​IMG]
     
  14. Eagle86K5

    Eagle86K5 1/2 ton status

    Joined:
    Mar 5, 2000
    Posts:
    974
    Likes Received:
    0
    Location:
    Whitehouse, Ohio
    My new free catalog from pace parts has some very nice looking guages that will go in the dash. Mechanical type not electric like what is in there, and you can get them in white face if you like... Semper Fi

    <font color=blue>http://www.paceparts.com
     

Share This Page