Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

What could it be,frame,balljoints ?????

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by NoSmog73, Mar 6, 2002.

  1. NoSmog73

    NoSmog73 1/2 ton status

    Joined:
    Sep 28, 2001
    Posts:
    2,348
    Likes Received:
    0
    Location:
    lodi,ca
    Ok I am taking the steering box off already and this is what is happening.
    When I turn the wheel to the side right or left maybe about 1/4 turn on the wheel there is a "POP"then nothing and then "POP" again..not at full turn or anywhere else in the turning..
    When it does pop standing out of the k5 and turning the wheel I can see the fender on the driver's side shake but the bumper really moves, bounce's
    I looked under the k5 when it is popping and there seams to be nothing under there that moves or bind's...
    Any thoughts welcome......thanks mike
     
  2. m j

    m j 1/2 ton status

    Joined:
    Dec 28, 2001
    Posts:
    4,606
    Likes Received:
    0
    leaf springs grinding back n forth
    try tightening the ubolts and throwing some grease between the leaves to see if it stops the sound.
    not a problem if thats all it is
     
  3. Triaged

    Triaged 1/2 ton status

    Joined:
    Feb 21, 2001
    Posts:
    3,808
    Likes Received:
    0
    Location:
    CA (LA/OC area)
    Try putting your hand on different parts (of the truck) when someone else turns the wheel...sometimes you can feal it but not see it.
     
  4. jimmyjack

    jimmyjack 1/2 ton status

    Joined:
    May 11, 2000
    Posts:
    2,290
    Likes Received:
    0
    Location:
    Tucson Az
    Check your leaf springs like mj said, crank down your u bolts too. Also check for cracks under your steering box.
     
  5. UseYourBlinker

    UseYourBlinker 1 ton status

    Joined:
    Jun 7, 2000
    Posts:
    11,117
    Likes Received:
    0
    Location:
    .
    Had a similar problem.. I put in a ORD steering brace and it went away. Figured it had something to do with the steering box bolts. Look for any cracks on the frame near the steering box.
     
  6. NoSmog73

    NoSmog73 1/2 ton status

    Joined:
    Sep 28, 2001
    Posts:
    2,348
    Likes Received:
    0
    Location:
    lodi,ca
    Hey that's an Idea (the leaf springs) Thanks for the suggestions I wouldn't have thought of that one.. Will look at sometime this week again thanks...mike
     
  7. 4X4HIGH

    4X4HIGH 1 ton status Premium Member GMOTM Winner

    Joined:
    Dec 14, 2001
    Posts:
    22,060
    Likes Received:
    69
    Location:
    Pleasanton, CA.
    I had this exact problem in my blazer before, turns out the steering box was bad. Have someone turn the wheels as you look at the sector shaft coming out of the steering box and watch to make sure it doesn't move in and out of the box as the wheels are being turned. My blazer also would feel like i lost the power steering when i would make a hard turn and also felt at that point like the steering locked up.
     
  8. NoSmog73

    NoSmog73 1/2 ton status

    Joined:
    Sep 28, 2001
    Posts:
    2,348
    Likes Received:
    0
    Location:
    lodi,ca
    Ya I have the new box and just did the pump just have to finish getting the old box off to see if I need to order the kit to repair (any) cracks or just the brace ....mike
     
  9. Chaz88K5

    Chaz88K5 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    2,979
    Likes Received:
    0
    Location:
    Stockton/Lodi CA
    ya know after reading about the u bolt thing i just had that problem after i put the d60 in..one side was kind loose making that poping noise...
     
  10. NoSmog73

    NoSmog73 1/2 ton status

    Joined:
    Sep 28, 2001
    Posts:
    2,348
    Likes Received:
    0
    Location:
    lodi,ca
    I hope it is that easy?????
     

Share This Page