Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

What did I do?

Discussion in 'The Garage' started by UseYourBlinker, Jul 1, 2002.

  1. UseYourBlinker

    UseYourBlinker 1 ton status

    Joined:
    Jun 7, 2000
    Posts:
    11,117
    Likes Received:
    0
    Location:
    .
    After Blazer-fest my steering wheel is not centered. I have to hold the wheel almost half a turn to the right,ust to be able to drive straight. What did I do? All the steering componet's look good. Nothing bent. /forums/images/icons/confused.gif
     
  2. NoSmog73

    NoSmog73 1/2 ton status

    Joined:
    Sep 28, 2001
    Posts:
    2,348
    Likes Received:
    0
    Location:
    lodi,ca
    Well I would say that you knocked it out of alinment or bent the tierod ??? You can center the wheel again by loosening the 2 bolts that hold the clampa on the I think drag link (i think that's what it is) then with a pipe wrench turn the middle rod(make sure your wheels are pointed straight first not the steering wheel)untill you see the wheel back to the center....mike
     
  3. HarryH3

    HarryH3 1 ton status Author

    Joined:
    May 31, 2000
    Posts:
    10,384
    Likes Received:
    2
    Location:
    Georgetown, TX
    Check for cracks in the frame around the steering box VERY closely. Something had to move or bend for that to happen.
     
  4. Greg72

    Greg72 "Might As Well..." Staff Member Super Moderator

    Joined:
    Mar 5, 2001
    Posts:
    15,683
    Likes Received:
    1,392
    Location:
    642 Days to BB2018
    Maybe you rolled....? /forums/images/icons/blush.gif

    My steering is doing the same thing. And I've had that same experience on previous off roading trips. Maybe I'm just not tightening those draglink bolts enough?
     
  5. FRIZZLEFRY

    FRIZZLEFRY 1/2 ton status

    Joined:
    Apr 20, 2001
    Posts:
    3,271
    Likes Received:
    134
    Location:
    Clovis CA
    Also check the torque on the front u bolts.If they are a little loose the front axle can move around a little and cause that problem /forums/images/icons/grin.gif
     
  6. 1979Jimmy

    1979Jimmy 1/2 ton status

    Joined:
    Nov 14, 2001
    Posts:
    696
    Likes Received:
    0
    Location:
    Danville Ca
    My truck was pulling when i was braking off and on on the way home i figure ill clean everything out real good and take it from there. I got a spare tie rod if you want it. Ill trade you for the trim. Give me a call if you want some help this week.
     
  7. m j

    m j 1/2 ton status

    Joined:
    Dec 28, 2001
    Posts:
    4,606
    Likes Received:
    0
    the draglink coupler piece bent a little on you.
    it is very soft
     

Share This Page