Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

What happened DeeVee8

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by wnderbra, Mar 9, 2000.

  1. wnderbra

    wnderbra Registered Member

    Joined:
    Feb 18, 2000
    Posts:
    47
    Likes Received:
    0
    Location:
    Virginia
    Just was curious if you solved the ignition problem. If not sorry to bring it up if so what was the problem. The info might come in handy
     
  2. Todd78/87

    Todd78/87 1/2 ton status

    Joined:
    Feb 18, 2000
    Posts:
    436
    Likes Received:
    0
    Location:
    Haines, Ak
    I'm curious also,,, it was kinda like a soap I got hooked on,, then you canceled the show!!! [​IMG]

    Todd 78/87[​IMG]
    [​IMG]
     
  3. Crash90K5

    Crash90K5 Registered Member

    Joined:
    Feb 17, 2000
    Posts:
    84
    Likes Received:
    0
    Location:
    Santa Clara, CA.
    Uhh... I hope you're talking soap as in Ivory Soap!! [​IMG]

    [​IMG] <font color=blue>Crash90K5</font color=blue> [​IMG]
     
  4. _DeeVee8_

    _DeeVee8_ 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    149
    Likes Received:
    0
    yeah, yeah, yeah... I know-- I'm a writer/ Advertiser-- Writing the script of my life so others won't fall into the same holes!

    The Problem --dead ignition...she just cranked and cranked and still no lightning!

    So I managed to find the best deal for a Distributor online at : http://www.summitracing.com

    No sticker shock either! My wallet looked thicker even as I was ordering the thing ($139.00)
    came with new cap and rotor-- was cheaper than NAPAS lovley remanufactured unit. This one looked nicer too, not that we drive down the road with the hood up anyway.

    You'all know I replaced everything else and still nothing-- then I put all the old stuff back in and pulled the distributor out and examined it. The bushings in the DIst were coroded and there was alot of free play within the shaft. That was enough for me-- also explained way there was much scorring inside the old Rotor cap. The pick up coil seemed to be fragged as well...
    NEXT DAY AIR-- the Distributor arrived with large Summit Catalog and I proceded to install the new unit.. Turned the shaft to slide in to the same position as the old unit, torqued it down and hooked up all my wires and hoses.
    Crossed my fingers and hid all the sharp objects that i could have jabbed myself with if it didn't start. Cranked it over ever so slightly and she caught on the first crank! How's that for ENTERTAINMENT?!!!!

    I advanced the timeing a tad to 4 degrees to see if I could eliminate the pinging but it didn't happen. HEY? I am just happy she's running and breathing again!

    So that's the story.
    I have ended out my post way back on page 26 or 27(i forget which)
    with a few footnotes.

    Now my thing is with the EGR not working/ it's not even seen anywhere in the engine bay!

    Thanks for following along with my plight--
    If you ever suspect that it might be the Distributor-- go with your guts instict and you're generally going to be right-- I was.

    -Woody
    Dv8
     
  5. Eagle86K5

    Eagle86K5 1/2 ton status

    Joined:
    Mar 5, 2000
    Posts:
    974
    Likes Received:
    0
    Location:
    Whitehouse, Ohio
    eyah....bout time...

    <font color=green>Eagle86K5

    <font color=red>Only guy I know that can get out of line in a one car funeral
     

Share This Page