Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

what the H*ll? my truck isnt working

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Marshall, Jan 12, 2003.

  1. Marshall

    Marshall 1/2 ton status

    Joined:
    Apr 8, 2002
    Posts:
    204
    Likes Received:
    0
    Location:
    LiveRmore,CA
    ok....i was driving on the freeway and all the sudden a loud boom followed with another one when i tried to accelerate off the freeway(almost like a misfire). The engine failed to start /forums/images/graemlins/angryfire.gif and we ended up haveing to take a tow truck home. what could be wrong...if you have any suggestions on what to try and find out what the problem is please let me know

    Thanks, Marshall

    350/208/3.73Gov-Lock/31"s/10Bolt
     
  2. BowtieBlazer

    BowtieBlazer 1/2 ton status

    Joined:
    Jul 15, 2001
    Posts:
    2,462
    Likes Received:
    0
    Location:
    Baton Rouge, Louisiana
    shot in the dark.... no fuel, clogged cattallitic convertor?, starter fell out in the road, battery turned over off the tray, engine exploded /forums/images/graemlins/confused.gif

    Was it an exhaust sound or a sound you felt in the floor board...under the hood? what? DETAILS?
     
  3. Marshall

    Marshall 1/2 ton status

    Joined:
    Apr 8, 2002
    Posts:
    204
    Likes Received:
    0
    Location:
    LiveRmore,CA
    I think my engine was missing, it was one sound a hard jerk and exaust sound. I checked the firing of the engine no spark at all but the engine does turn over. I think my distributor took a crap
     
  4. BowtieBlazer

    BowtieBlazer 1/2 ton status

    Joined:
    Jul 15, 2001
    Posts:
    2,462
    Likes Received:
    0
    Location:
    Baton Rouge, Louisiana
    thats exactly what it sounds like...a junker distributor can be had for a cheap price just to test out the theory
     
  5. Overkill

    Overkill 1/2 ton status

    Joined:
    Jan 15, 2002
    Posts:
    284
    Likes Received:
    0
    Location:
    Orlando, Florida
    Might want to check to see if the timing chain went south on ya too. Its easy to check, pull the distributor cap off and turn it over, it the rotor turns chain is intact, maybe off a few teeth but intact. Just a thought....
     
  6. 74Chev

    74Chev 1/2 ton status

    Joined:
    Sep 19, 2002
    Posts:
    102
    Likes Received:
    0
    Location:
    Oregon
    I'd put money on the ignition module in the distributor. This is often overlooked in trouble shooting GM no start conditions. I have suggested that this was the problem to two friends whose trucks did the same thing and both times new module=truck running again.
     
  7. BowtieBlazer

    BowtieBlazer 1/2 ton status

    Joined:
    Jul 15, 2001
    Posts:
    2,462
    Likes Received:
    0
    Location:
    Baton Rouge, Louisiana
    I could second that as I had a truck do the same with a bad ignition module...
     
  8. BowtieBlazer

    BowtieBlazer 1/2 ton status

    Joined:
    Jul 15, 2001
    Posts:
    2,462
    Likes Received:
    0
    Location:
    Baton Rouge, Louisiana
    I could second that as I had a truck do the same with a bad ignition module...
     
  9. Blue85

    Blue85 Troll Premium Member

    Joined:
    Jul 26, 2000
    Posts:
    9,073
    Likes Received:
    486
    Location:
    Grand Rapids area
    I had that happen to me once. After I pulled over, I walked back along the roadside to a steaming place and picked up a piece of my connecting rod. /forums/images/graemlins/frown.gif Hope your problem is less severe. /forums/images/graemlins/k5.gif
     
  10. schmuck

    schmuck 1/2 ton status

    Joined:
    Nov 11, 2002
    Posts:
    523
    Likes Received:
    0
    Location:
    nola(new orleans LA)
    if you replace the module and it still isnt working try pulling the distrbutor out and try using a earlyer module with 4 prongs instead of five on the bench if you can get it to work out of the truck that way then your computer is bad
     
  11. Marshall

    Marshall 1/2 ton status

    Joined:
    Apr 8, 2002
    Posts:
    204
    Likes Received:
    0
    Location:
    LiveRmore,CA
    Yea...i think it is the ignition module, either that or the coil. I changed the cap and rotor for the heck of it. Thanks for everyones help.
     
  12. Marshall

    Marshall 1/2 ton status

    Joined:
    Apr 8, 2002
    Posts:
    204
    Likes Received:
    0
    Location:
    LiveRmore,CA
    my truck isnt working(please help updated)

    well i changed the ignition module and no go.I checked to see if there was a spark and it was really weak, but on time. I think the coil might be the next step anyone else have any advice?
     
  13. Marshall

    Marshall 1/2 ton status

    Joined:
    Apr 8, 2002
    Posts:
    204
    Likes Received:
    0
    Location:
    LiveRmore,CA
    Re: my truck isnt working(please help updated)

    allright my truck finally works and it runs better than it ever did.... The coil was crapin out so i put a MSD Blaster coil in and mounted the stock bracket.Idles smooth has more power and acceleration....that could be because i pretty much replaced the whole igniton system /forums/images/graemlins/eek.gif but know my truck runs agian /forums/images/graemlins/pimp1.gif /forums/images/graemlins/k5.gif. Thanks for everyones help.

    Marshall

    350/208/10Bolt/3.73Gov-Lock/31"s
     

Share This Page