Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

What the he_ _ is wrong with my wipers

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by WILL, Apr 15, 2001.

  1. WILL

    WILL Registered Member

    Joined:
    Feb 4, 2001
    Posts:
    44
    Likes Received:
    0
    Location:
    Indiana
    My wipers are really freaky, they work when they want and dont turn off sometimes. Does anyone know how to solve the problem and where to get the parts at the best prices? Thanks
     
  2. nyyef

    nyyef 1/2 ton status

    Joined:
    May 16, 2000
    Posts:
    479
    Likes Received:
    0
    Location:
    Saudi Arabia
    i just replaced my motor and pump, they were doing scaaaarrrryyy things. now they work great!
    but i have heard that replacing the motor does always help. the mechanism that is under the cowl/dash can sometimes bind.

    Knife.
    knife.coloradok5.com
     
  3. Can Can

    Can Can Pusher Man Staff Member Super Moderator

    Joined:
    Feb 17, 2000
    Posts:
    15,552
    Likes Received:
    136
    Location:
    Cochrane, Alberta, Canada
    It could also have something to do with the wiring that goes through your steering column. I had a short at the pivot point on my tilt column- the coating had worn away and exposed a couple of the wires. My wipers started acting like yours and then one day...............<font color=red>POOF</font color=red>!!!!!!!!!!!!!............the whole harness melted out. I lost my wipers, my cruise control, and around $300 in parts and labor to get everything repaired.

    If you can rule out a bad wiper motor, take a look at your wiring and make sure that everything's intact and there's no wear on the wire coating. If you fry your column wiring you're in for a major headache.


    <font color=red>PHOTO ALBUM-</font color=red> <A target="_blank" HREF=http://albums.photopoint.com/j/AlbumList?u=1289798>http://albums.photopoint.com/j/AlbumList?u=1289798</A>.......<font color=blue>TRUCK & HIKING PICS</font color=blue>
     
  4. jimmyjack

    jimmyjack 1/2 ton status

    Joined:
    May 11, 2000
    Posts:
    2,290
    Likes Received:
    0
    Location:
    Tucson Az
    Every once in awhile mine crap during a good rain shower. It turned out the fuse was corroded. I sprayed some contact cleaner in there, gave the new fuse a little twist and all is well,,,, Its worth a shot.

    "My blazer may be slow, but it goes faster at higher speeds"

    Jim
     
  5. K5blazer

    K5blazer Registered Member

    Joined:
    Feb 8, 2001
    Posts:
    12
    Likes Received:
    0
    My wipers were the same way, staying on and all that crap. Put in a new motor and they work great.
     
  6. Pure Insanity

    Pure Insanity 1/2 ton status

    Joined:
    Mar 17, 2001
    Posts:
    4,579
    Likes Received:
    0
    Location:
    Dade City, Florida
    HAHAHAHAAH!i was bragging about not having phantom wipers earlier today,and guess what!?!i turned them on they went to the top and stopped!!!i find it hillarious myself.but ive got a weird sense of humor[​IMG]so now theyre stuck straight up.ill look into it.

    PURE INSANITY
    86 blazer see it at:<A target="_blank" HREF=http://www.zing.com/album/pictures.html?id=4292792569>http://www.zing.com/album/pictures.html?id=4292792569</A>
     
  7. mattman

    mattman 1/2 ton status

    Joined:
    Feb 15, 2001
    Posts:
    152
    Likes Received:
    0
    Location:
    Austin, Texas
    Mine had a problem with not turning off. Turn to the mist position and they would turn off. Went like this for years until the switch crapped out and now has no positions. In the process of trying to replace the switch which is a real bear. Hopefully this will solve the problem and nothing else is wrong.

    90 GMC Jimmy, 350 TBI, 700R4, 32's
    84 Bronco II 204,000 miles and counting...........
     

Share This Page