Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

What waterpump did those of you with a serp. belt swap use?

Discussion in 'The Garage' started by 55Willy, Aug 16, 2004.

  1. 55Willy

    55Willy 3/4 ton status

    Joined:
    Jun 2, 2001
    Posts:
    9,946
    Likes Received:
    0
    Location:
    Keizer, Or
    I was getting the run around with the two parts people yesterday. and I said a 92 k1500 pick up. they listed two different ones depending on auto or manual. so I said 90 camaro 305 (which my TBI came off of) same two mumbers i asked if it had to do with the heater hose fitting, they said yes...I said theres no heater core in it,LOL But the price difference is HUGE and I plan to add a heater core to it...actually 3 /forums/images/graemlins/whistling.gif

    which do i use?

    I'd had to wait 3 weeks to just get it while I am back in Eugene and I can look it all up at the store i worked it but I feel like I'm better off doing it that way. /forums/images/graemlins/doah.gif
     
  2. Emmettology 101

    Emmettology 101 3/4 ton status

    Joined:
    May 9, 2000
    Posts:
    8,126
    Likes Received:
    0
    Location:
    FL
    /forums/images/graemlins/dunno.gif Mine has a stock 89 reman pump on it right now. But I do have a Flowcooler pump sitting in the garage for it. The thing doesn't run hot, so I haven't swapped it in yet.

    If the differences are just in the heater hose fittings, why not just buy the cheaper one since, you wont be using them?
     
  3. ZooMad75

    ZooMad75 1/2 ton status Premium Member GMOTM Winner

    Joined:
    Apr 5, 2003
    Posts:
    999
    Likes Received:
    593
    Location:
    Pueblo, CO
    Any long water pump will work as long as it is reverse rotation (for serpentine use only!!). Mine is from any 88-95 pickup. Mine never ever runs hot, even on the hottest days it runs a quarter up the gauge from the "C" mark.

    Thats with the stock 3 core radiator too.

    I have seen an nieghbor of mine use a standard rotation pump on a serpentine system though. He just dumped a 400sb in place of a 305 in a 88 pickup. He thought the 400 needed a better water pump so he shelled out the bucks for a Edlebrock unit from summit and used the serpentine setup off of the 305. The engine would not cool off at all. Not trying to come off as a smart a$$ I asked if the e-brock pump was reverse rotation. He said he got what summit said would work on his 400. After trying to explain standard rotation and reverse rotation for a few minutes he just looked at me puzzled. I had to pop the hood on my Nova and show him which way a standard pump turns and then had him look at his. The light lit up over his head! We swapped the old pump off of the 305 and it started cooling like it should!
     
  4. kazajames56

    kazajames56 Registered Member

    Joined:
    Jun 13, 2003
    Posts:
    28
    Likes Received:
    0
    Location:
    Kenner, LA
    I used one off of an 89 Suburban and it works fine... just a heads up here but make sure the fan is for reverse rotation as well (I'm sure you know this already though).

    Steve
     
  5. 55Willy

    55Willy 3/4 ton status

    Joined:
    Jun 2, 2001
    Posts:
    9,946
    Likes Received:
    0
    Location:
    Keizer, Or
    the fans a tuarus unit, all i have room for.
     

Share This Page