Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Whats wrong with my Spedometer?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 78Blazer, Mar 15, 2001.

  1. 78Blazer

    78Blazer 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    873
    Likes Received:
    0
    Location:
    Michigan
    Ok when I was driving my 78 the speedometer quit working I thought it was the cable but never messed with it, Now that I have tore it all apart and put it into my 84 with a new cable it still does not work. I know the cable and guage are good so what else can cause this?



    Scott
    78blazer
     
  2. jimmyjack

    jimmyjack 1/2 ton status

    Joined:
    May 11, 2000
    Posts:
    2,290
    Likes Received:
    0
    Location:
    Tucson Az
    It sounds like the speedo gear in you t case might be bad.

    creepin' and crawlin'

    Jim
     
  3. 78Blazer

    78Blazer 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    873
    Likes Received:
    0
    Location:
    Michigan
    Whats involved with this and how hard is it to change?

    thanks


    Scott
    78blazer
     
  4. bigjbear

    bigjbear 1 ton status Staff Member Moderator

    Joined:
    Feb 18, 2000
    Posts:
    13,970
    Likes Received:
    449
    Location:
    Marietta GA
    If you have it hooked up to an old style cruise control this could also be the problem. It will be on the L/H inner fender. The gears in there can get stripped or jammed.

    Jim '80 GMC
    Freedom First!
    <A target="_blank" HREF=http://www.bigjbear.coloradok5.com>http://www.bigjbear.coloradok5.com</A>
     
  5. 78Blazer

    78Blazer 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    873
    Likes Received:
    0
    Location:
    Michigan
    I no longer have cruise on it all that was taken off it just goes straight to the tcase.



    Scott
    78blazer
     
  6. muddin4fun

    muddin4fun 3/4 ton status

    Joined:
    Feb 19, 2001
    Posts:
    5,644
    Likes Received:
    0
    Location:
    N Texas
    Pull the speedo out and drive it and see if you can see the cable spinning. If it does, you either don't have the cable pushed in all the way or your speedo is screwed. If it doesn't spin, then it's a gear in your t-case.

    [​IMG] Keep your feet dry [​IMG]
    <A target="_blank" HREF=http://muddin4fun.coloradok5.com>http://muddin4fun.coloradok5.com</A>
     
  7. Ditchdigger

    Ditchdigger Registered Member

    Joined:
    Mar 11, 2001
    Posts:
    96
    Likes Received:
    0
    Location:
    The Great Midwest
    Betcha, its your gears assuming you've checked your speedo
    and cable make sure the cable ends fit right and put a little grease in there!
     

Share This Page