Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

When does it end?!?!?!? *got the codes it threw*

Discussion in 'The Garage' started by Avery4jc, Apr 20, 2007.

  1. Avery4jc

    Avery4jc 1 ton status Premium Member GMOTM Winner

    Joined:
    Oct 24, 2005
    Posts:
    10,760
    Likes Received:
    75
    Location:
    Fresno, Ca.
    I was driving home from work tonight and was cruising down the freeway when I heard this huge POP...sort of like a small explosion...and then my check engine light came on and the engine fell flat on its face...

    I made it home but it had absolutely no power at all and I was starting to smell a mixture of what I think was burnt oil and gas.
    I got home and popped the hood and now it sounds different than it used to...I checked all the plug wires and they are all good so I think its something major.

    Its not smoking but it has this distinct sort of hissing/pop noise and if I get into the throttle it backfires like crazy when the rpms are dropping...

    WTF bros?!!?!?! When can I catch a break!?!
     
    Last edited: Apr 21, 2007
  2. mostwanted

    mostwanted 1/2 ton status

    Joined:
    Feb 5, 2006
    Posts:
    765
    Likes Received:
    0
    Location:
    Kansas City, MO
    sounds major to me. Did you check your oil to see if it was contaminated?
     
  3. MuddinManny

    MuddinManny Banned

    Joined:
    Oct 18, 2006
    Posts:
    1,106
    Likes Received:
    0
    Location:
    USA
    1. Check the area of the rear main seal. Any oil dripping?
    2. Check the air cleaner, see if the carb backfired, blew out the valves
    3. Check the valve covers to make sure you didn't throw a rod
    4. Check the heads to see if you blew out the head gasket(s).
    5. Check the oil for contamination, as mentioned, and the oil filter
    6. Check radiator and all heater hoses
    7. Check the condition of the transmission and its fluid.

    We need a little more information to help, bud.

    A. Did your oil pressure drop after the initial "pop"? If so, to what?
    B. Did your engine overheat?
    C. What was the condition of your tranny?
    D. Did your tranny continue to shift?

    I know it's upsetting. Calm down and work through it slowly.
    On standby to help.

    Manny


    ....sounds like the tranny locked up.
     
  4. Avery4jc

    Avery4jc 1 ton status Premium Member GMOTM Winner

    Joined:
    Oct 24, 2005
    Posts:
    10,760
    Likes Received:
    75
    Location:
    Fresno, Ca.
    I'll go out after dinner and check the stuff on that list.

    The oil pressure stayed the same and its not dripping from anywhere...

    iono about overheating b/c my temp guage has never worked...

    The tranny was fine...shifted perfectly but the engine just didn't have much power to get rolling quickly...


    My dad just got home from work and he looked at it and said that our best bet is to take it to the smog shop (my buddy's shop here in town) and let him figure out why that check engine light popped on b/c isn't the light tied into the smog system?
     
  5. stoney126

    stoney126 1/2 ton status

    Joined:
    Jun 2, 2005
    Posts:
    1,458
    Likes Received:
    0
    Location:
    napa,CA
    to awnser your first question ... No never.:D
     
  6. ryoken

    ryoken Puppy Fabricator Premium Member GMOTM Winner

    Joined:
    Jun 13, 2003
    Posts:
    29,624
    Likes Received:
    1,380
    Location:
    Jersey Shore
    check and see what code it threw, that IS what that light is for...
     
  7. Avery4jc

    Avery4jc 1 ton status Premium Member GMOTM Winner

    Joined:
    Oct 24, 2005
    Posts:
    10,760
    Likes Received:
    75
    Location:
    Fresno, Ca.
    yeah but the only way to do that is to hook it up to the computer at the smog station right?
     
  8. ryoken

    ryoken Puppy Fabricator Premium Member GMOTM Winner

    Joined:
    Jun 13, 2003
    Posts:
    29,624
    Likes Received:
    1,380
    Location:
    Jersey Shore
  9. USAJon

    USAJon 1/2 ton status

    Joined:
    Sep 8, 2006
    Posts:
    125
    Likes Received:
    0
    Location:
    Silver Spring, Maryland U.S.A.
    if you let off the throttle then this occure it may be it jumped time...I did this once slowing down off a hwy to exit..pop! no power...jumped time . had to replace motor. bent valves et al. ran but poor. may be the worst...
     
  10. k20

    k20 3/4 ton status

    Joined:
    Sep 9, 2001
    Posts:
    5,068
    Likes Received:
    0
    Location:
    Mineral Springs, NC
    Mine did that, I broke a rocker, bent a pushrod, and broke a guideplate......:crazy:
     
  11. broncoman6524

    broncoman6524 1/2 ton status

    Joined:
    Oct 31, 2005
    Posts:
    2,469
    Likes Received:
    0
    Location:
    chuluota Fl
    when yuo accelerate does it make a any noises?

    if so...double knocl-rod bearings
    constant ticking-valve MAJORLY outa adjustment...

    good luck bro! just CALM DOWN! maybe the bottom end is good nad it just needs a new topend...hmmm vortec heads? Cam? geardrive!?

    just gotta look ont he bright side of it!
     
  12. Avery4jc

    Avery4jc 1 ton status Premium Member GMOTM Winner

    Joined:
    Oct 24, 2005
    Posts:
    10,760
    Likes Received:
    75
    Location:
    Fresno, Ca.
    no it sounds normal under acceleration but that may be b/c my exhaust is so loud thats all you hear anyways.
    I hear the weird air sound at idle and then the backfires when it decelerates...but thats it.
     
  13. k20

    k20 3/4 ton status

    Joined:
    Sep 9, 2001
    Posts:
    5,068
    Likes Received:
    0
    Location:
    Mineral Springs, NC
    Those symptoms sound alot like mine did.......
     
  14. broncoman6524

    broncoman6524 1/2 ton status

    Joined:
    Oct 31, 2005
    Posts:
    2,469
    Likes Received:
    0
    Location:
    chuluota Fl
    nah if its what i was descibing youd feel/hear it...soo when yuo let off the gas and it slows it kinda burps? or backfires? carb or exhaust?
     
  15. MuddinManny

    MuddinManny Banned

    Joined:
    Oct 18, 2006
    Posts:
    1,106
    Likes Received:
    0
    Location:
    USA
    My thinking is either head gasket or exhaust manifold gaskets. Quick check of the air filter should tell if the carb burped and blew the power valves out of the carb.
     
  16. broncoman6524

    broncoman6524 1/2 ton status

    Joined:
    Oct 31, 2005
    Posts:
    2,469
    Likes Received:
    0
    Location:
    chuluota Fl
    take starter fluid and just spray it between the head and intake,and around the carb. OR put your hands over the carb to stop airflow..if it slows the intake is sealed if it speeds up or stays hte same...theres obviously a leak in teh intake.
     
  17. 4X4HIGH

    4X4HIGH 1 ton status Premium Member GMOTM Winner

    Joined:
    Dec 14, 2001
    Posts:
    22,062
    Likes Received:
    69
    Location:
    Pleasanton, CA.
    Check for any vacuum lines that popped off. Also check what code it pulled, this will give you a good starting point.
     
  18. mostwanted

    mostwanted 1/2 ton status

    Joined:
    Feb 5, 2006
    Posts:
    765
    Likes Received:
    0
    Location:
    Kansas City, MO
    I know one thing: If it were me, I wouldn't wait around till the shop opened up to figure it out. Unless you make lotsa$$, (and I know u don't) you are gonna have to tear into this kinda stuff yourself. If you suspect timing, put the motor at TDC and check your distributor. But I would look at your carb for backfire and do the starting fluid test first.
     
  19. Xtremegmc80

    Xtremegmc80 1/2 ton status Premium Member

    Joined:
    Mar 19, 2007
    Posts:
    1,976
    Likes Received:
    14
    Location:
    NE PA
    happened to my camaro z28.. back fired then next thing i remember is lost all of the power. then smoke.. caught on fire, never got that engine running again.. tried to fix it, no luck. ended up with a new engine. started right up.. so not sure if ur is major or minor.. check everything that was mentioned. u try to put it in netural and rev up the engine? umm was ur distrubor loose? cause if it turned it can happen. check inside disturbor cap and make sure the rotor isnt loosed. thats all i can think of.. i might have forgotten something.. thats whats everyone else for.. to help sort out the problems. just hope its not the engine..
     
  20. rjfguitar

    rjfguitar 3/4 ton status GMOTM Winner

    Joined:
    Aug 28, 2002
    Posts:
    9,097
    Likes Received:
    144
    Location:
    california
    Highly doubt it's major, most likely in your fuel and/or timing. Especially, since the ECM sees there is something wrong triggering the light.
     

Share This Page