Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Where does the O2 sensor plug in (no, not a joke)?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by BigEasy, Dec 25, 2006.

  1. BigEasy

    BigEasy 1/2 ton status

    Joined:
    Dec 18, 2006
    Posts:
    418
    Likes Received:
    0
    Location:
    U-jeen, Oragun
    Truck's been running a little rough lately, so I decided to install some new plugs & wires today, new oil & filter, & a new O2 sensor. When I reached up to remove the old sensor, the connecting wire was just hanging there. Don't know if it was that way when I bought it, or it recently came loose... But the problem is that I can't find the plug to plug the new sensor back in! :doah: I've been on top of the motor and under the truck 3 times each, still don't see it... The only thing close are the wires coming from the tranny and the spark plug wires. Can somebody PLEASE tell me where the other plug comes from (what wire loom/direction/etc.)??? :confused: Also, it's a '90 GMC Jimmy w/5.7 TBI if that matters.
     
    Last edited: Dec 25, 2006
  2. fortcollinsram

    fortcollinsram 1/2 ton status

    Joined:
    Nov 8, 2001
    Posts:
    2,261
    Likes Received:
    0
    Location:
    Fort Collins, CO
    it is a purple wire on the driver side of the engine...Has a barrel-type weather -pack connector..
     
  3. BigEasy

    BigEasy 1/2 ton status

    Joined:
    Dec 18, 2006
    Posts:
    418
    Likes Received:
    0
    Location:
    U-jeen, Oragun
    Ok, purple wire... I kinda figured what the connector should look like by the connector on the sensor. Can you tell me where the purple wire runs to? I don't see anything coming off the main ECM up by the brake booster, and there doesn't appear to be anything coming through the firewall or coming out of the loom where the tranny wires are. This has me totally stumped, and it's something so simple that it's frustrating the hell outta me... :1zhelp:
     
  4. southernspeed

    southernspeed 1/2 ton status GMOTM Winner

    Joined:
    Dec 24, 2003
    Posts:
    4,395
    Likes Received:
    50
    Location:
    VA
    As far as I can remember on mine it came out of the plastic sheathing on the loom that runs across the bulkhead behind the dizzy. Single purple wire with the connector as mentioned. That then runs off to the ecu.
     
  5. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,975
    Likes Received:
    189
    Location:
    Roy WA
    Isn't the sensor port on the TBI trucks in the drivers exhaust manifold, sort of angled toward the firewall?

    And yes, the O2 wire will be in the loom, going to the ECM through the hole in the firewall on the passenger side with all the other ones to the ECM.
     
  6. sweetk30

    sweetk30 professional hooker Premium Member

    Joined:
    Nov 1, 2004
    Posts:
    25,534
    Likes Received:
    531
    Location:
    horseheads , ny 14845
    left head side of the block at the big wire loom . mine just bairly hangs out of there.
     

Share This Page