Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Where is the oil pressure guage sending unit on an 89 sub?

Discussion in 'The Garage' started by Canadianbuilder, Nov 14, 2006.

  1. Canadianbuilder

    Canadianbuilder Registered Member

    Joined:
    Jan 23, 2005
    Posts:
    31
    Likes Received:
    0
    Location:
    Thunder Bay Ontario Canada
    i bought a f.i. 89 sub minus the engine and trans.I swapped in a small block from an 88 extended cab.When I was doing the swap I noticed the sending unit at the back of the engine below the distributor didn`t match the plug on the sub wiring harness.I took the sending unit from a small block from a 89 crewcab I had and put it on the engine I put in the sub because it matched the wiring harness plug.I thought the extra wire in the plug was for my oil pressure guage.Unfortunately my guage isn`t working.The needle is always pegged to the right.I noticed the 88 engine has a sending unit at the back of the engine on the drivers side.Is this the actual oil pressure sending unit?If so I can`t find a corresponding wire with a spade terminal in the sub harness to connect to the sending unit.Am I just not seeing the wire?or is that sending unit for the guage in the 88 style trucks only?Thanks.
     
  2. 4xcrazy

    4xcrazy 3/4 ton status

    Joined:
    Oct 31, 2003
    Posts:
    9,471
    Likes Received:
    5
    Location:
    Olympia/Lacey, Washington
    There were a couple of different style of plugs, i found this out tryint to troubleshoot a problem awhile back, either a two or a three wire plug, need the right one for that setup. Not exactly sure what you have goin on though, kinda tired, and can't think too well at the moment :p:

    some others will pop in here in a few to give alittle more detail as to what i am trying to get at.
     
  3. Canadianbuilder

    Canadianbuilder Registered Member

    Joined:
    Jan 23, 2005
    Posts:
    31
    Likes Received:
    0
    Location:
    Thunder Bay Ontario Canada
    Thanks 4xcrazy.Yeah the sub has a 3 wire plug and the donor engine had a 2 wire sending unit.I took a three wire sending unit off another engine I had from an 89 f.i crewcab and put it on the donor engine but the guage doesn`t work.Thought maybe there was another wire to go to the other sending unit the donor engine has.I guess the other sending unit is just for the 88 style trucks.I guess maybe the pressure guage might ****ed but I think I changed it.I can`t remember though been a year since I worked on it.Any chance the guage has a bad ground?If so anyone know where the ground for it is?Thanks
     
  4. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,979
    Likes Received:
    189
    Location:
    Roy WA
    Three wire combines the oil pressure switch and the gauge sender from the previous single wire oil pressure sender/dual wire oil pressure switch.

    You too can run it this way, I like it better, cleaner, less parts, etc.

    A wiring manual of the correct year truck should indicate how they are wired, or you can go to Napa and look in their Echlin catalog at the senders, those too show wiring of the senders.
     

Share This Page