Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

white smoke and bog

Discussion in '1982-Present GM Diesel' started by blasterD, Apr 15, 2004.

  1. blasterD

    blasterD 1/2 ton status

    Joined:
    May 24, 2003
    Posts:
    410
    Likes Received:
    0
    Location:
    Anchorage Alaska
    I'm pretty new to the diesel scene. I bought an 84 k30 with a 6.2 and a 465. It has a 4" Skyjacker lift and 315/70-17 tires (about 35-12.5) abd 4.10 gear ratio. It starts and runs good, but my fuel mileage is a litle less than I think it should be. I'm getting about 12-13 mpg with combined city/highway. I'm pretty sure the 4.10's and no overdrive contribute a lot to the mileage problem (cruise rpm on the highway is about 2600-2700rpm), but there is another problem. During hard acceleration 1/2-3/4 throttle (usually when the engine is not fully up to temp) I get an intermittent bog. As soon as the engine bogs, white smoke comes out the exaust. If I let off and then get back into it the bog and smoke go away. It doesn't happen very often, and when it does happen it only lasts 1-2 seconds. Does anybody have any ideas? I was thinking that it may be a short drop in fuel pressure possibly due to a bad injector pump or plugged fuel filter. Does a lean condition in a diesel cause white smoke? /forums/images/graemlins/thumb.gif
     
  2. azblazor

    azblazor 1/2 ton status Premium Member

    Joined:
    May 5, 2001
    Posts:
    1,953
    Likes Received:
    0
    Location:
    Arizona, Phoenix area
    White smoke is usually associated with UN burned fuel. Such as when the diesel is started. You might have a condition which is causing a cylinder to not combust it's fuel load....maybe a valve train issue? Any problems with loss of coolant (head gasket)? Have you done a compression test(rings and valves)?
     
  3. BlueBlazer

    BlueBlazer 1/2 ton status

    Joined:
    Feb 15, 2001
    Posts:
    1,940
    Likes Received:
    0
    If its intermittant like that I am thinking it could be water in the fuel.
     
  4. blasterD

    blasterD 1/2 ton status

    Joined:
    May 24, 2003
    Posts:
    410
    Likes Received:
    0
    Location:
    Anchorage Alaska
    I haven't had any loss of coolant. I haven't tested the compression. Does the fuel mileage I'm getting sound about right?
     
  5. azblazor

    azblazor 1/2 ton status Premium Member

    Joined:
    May 5, 2001
    Posts:
    1,953
    Likes Received:
    0
    Location:
    Arizona, Phoenix area
    My K30 SRW 6.2 TH400/NP205 4.56 w/30" tires gets 15-16'ish combined driving. My K30 CC DRW 6.2 TH400/NP205 Banks/GV 31" tires with the pump turned up gets a little better on the highway and a little worse in town.
     
  6. imiceman44

    imiceman44 1 ton status

    Joined:
    Aug 5, 2002
    Posts:
    15,160
    Likes Received:
    1
    Location:
    Sacramento, CA
    [ QUOTE ]
    I haven't had any loss of coolant. I haven't tested the compression. Does the fuel mileage I'm getting sound about right?

    [/ QUOTE ]
    My friend had the same symptoms and same mileage, he pop tested the injectors and they were poping at 20 PSI.
    Changed them out and now it runs better, and mileage is up to 16MPG.
    He has 4.56 gears with low profile tires so mileage could be better with stock tires. /forums/images/graemlins/grin.gif

    Check your injectors. /forums/images/graemlins/thumb.gif
     
  7. blasterD

    blasterD 1/2 ton status

    Joined:
    May 24, 2003
    Posts:
    410
    Likes Received:
    0
    Location:
    Anchorage Alaska
    Where is the best place to buy new injectors? Also, are there different kinds? Which is the best one?
     

Share This Page