Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Who is running roller rockers WITH TBI ***UPDATE***???

Discussion in 'The Garage' started by fortcollinsram, Jun 4, 2004.

  1. fortcollinsram

    fortcollinsram 1/2 ton status

    Joined:
    Nov 8, 2001
    Posts:
    2,261
    Likes Received:
    0
    Location:
    Fort Collins, CO
    I was just curious if anyone else has roller rockers on a TBI motor. I have a feeling that my knock sensor is picking up the ticking of my roller rockers and retarding the timing on my BBC once in a while. I really only notice it on WOT runs to like 5000rpm. It is NOT detonating at all...It does on 85 octane but has never (that I can tell) on 87 or 91.... So I was curious if anybody else has had this happen...I have the stock rockers I may throw on there to see if they make a difference...



    Update below!!!! octane problem...
    Chris
     
  2. sled_dog

    sled_dog 1 ton status

    Joined:
    Sep 3, 2002
    Posts:
    16,870
    Likes Received:
    0
    Location:
    Austin, TX
    Re: Who is running roller rockers WITH TBI???

    why are your roller rockers ticking? if its a hydraulic cam they should be zero lash just like anything else.
     
  3. Thunder

    Thunder 3/4 ton status

    Joined:
    Jul 20, 2000
    Posts:
    8,946
    Likes Received:
    1
    Location:
    Northeast Nevada
    Re: Who is running roller rockers WITH TBI???

    Have you hooked it up to a scannner and checked if you are getting knock counts? You could also have a fuel delivery problem at WOT. Making it run a little lean. Pretty common problem with TBI.
     
  4. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,975
    Likes Received:
    189
    Location:
    Roy WA
    Re: Who is running roller rockers WITH TBI???

    I'd seriously doubt roller rockers working properly would be anywhere near the frequency the knock sensor is listening for.

    People run gear drives on injected motors without problems, and thats a LOT more "noise" than the rockers make.

    FWIW I've got rollers on my TPI, and they aren't being picked up by the knock sensor. (same setup as TBI for knock)
     
  5. Triaged

    Triaged 1/2 ton status

    Joined:
    Feb 21, 2001
    Posts:
    3,808
    Likes Received:
    0
    Location:
    CA (LA/OC area)
    Re: Who is running roller rockers WITH TBI???

    [ QUOTE ]
    It is NOT detonating at all...It does on 85 octane but has nver on 87 or 91.... So I was curious if anybody else has had this happen...I have the stock rockers I may throw on there to see if they make a difference...

    Chris

    [/ QUOTE ]

    Let me get this straight...you have the problem with 87 and not with 89 or 91 and you think it is something othen then knock?
     
  6. BurbinOR

    BurbinOR 3/4 ton status

    Joined:
    Feb 17, 2000
    Posts:
    5,829
    Likes Received:
    0
    Location:
    Oregon
    Re: Who is running roller rockers WITH TBI???

    I did on my TPI motor, no issues with the knock sensor.
     
  7. K5er4Life

    K5er4Life 1/2 ton status

    Joined:
    Oct 16, 2002
    Posts:
    1,456
    Likes Received:
    0
    Location:
    Bellflower, Ca
    Re: Who is running roller rockers WITH TBI???

    Got rollers on my TBI'ed 383 and have no problems with the knock sensor picking them up.
     
  8. sjeccles

    sjeccles Registered Member

    Joined:
    May 13, 2001
    Posts:
    27
    Likes Received:
    0
    Location:
    Iowa
    Re: Who is running roller rockers WITH TBI???

    I have been running rollers for a year in my 90(TBI) with no problems
     
  9. fortcollinsram

    fortcollinsram 1/2 ton status

    Joined:
    Nov 8, 2001
    Posts:
    2,261
    Likes Received:
    0
    Location:
    Fort Collins, CO
    Re: Who is running roller rockers WITH TBI???

    figured it out...I ran it by my buddy's shop and we hooked the scanner to it and it turns out it WAS detonating a little at WOT with the 87octane gas and the timing advance was jumping all over the place so I filled up at 1/4 tank with of 91 and it runs like a raped ape. I never really did calculat the compression so I guess it is higher than I thought...

    Thanks gang

    Chris /forums/images/graemlins/thumb.gif
     

Share This Page