Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

wierd electrical problems..please help!

Discussion in 'The Garage' started by bryguy00b, Mar 26, 2003.

  1. bryguy00b

    bryguy00b 3/4 ton status

    Joined:
    Apr 7, 2002
    Posts:
    5,587
    Likes Received:
    0
    Location:
    Rochester, N.Y
    ok...im so pissed right now..i just got back fomr an hour and a half trip for nothing..trying to find this f-ing guys house in the middle of rush hour to look at a tailgate for my truck..well i never found it..i think the guys on crack..AND....half way...my truck goes wacko..and im scared. i statrted smelling this smoke..and i look at my temp gauge..and its flipping out at me my gas guage has dropped pased E..and nothing works...no lights/wipers/heat/ac/blinkers work sometimes..but it either clicks...or the light will come on steady, or it just wont work and sometimes the guages will move to the clicking!!! i left everything was fine!! what the frick happened!!??
     
  2. bablazer73

    bablazer73 1/2 ton status

    Joined:
    Apr 4, 2000
    Posts:
    3,363
    Likes Received:
    0
    Location:
    upstate ny
    Re: what the @!#@!$#@!$@!@!

    sounds like a fuseable link or some sort of wire went up in smoke.
     
  3. bryguy00b

    bryguy00b 3/4 ton status

    Joined:
    Apr 7, 2002
    Posts:
    5,587
    Likes Received:
    0
    Location:
    Rochester, N.Y
    Re: what the @!#@!$#@!$@!@!

    haha probobly good god what else can happen to me..ill NEVER be alble to tell what it is...ill have to take it someplace i guess...
     
  4. rebelk5frk

    rebelk5frk 1/2 ton status

    Joined:
    Dec 29, 2001
    Posts:
    815
    Likes Received:
    0
    Location:
    Houston, TX
    Re: what the @!#@!$#@!$@!@!

    As many wiring problems that you've been having it might just be easier to gut all the wiring and hook up a "painless wiring harness" They aren't too cheap but neither is taking it in to the shop for wiring issues.
     
  5. bryguy00b

    bryguy00b 3/4 ton status

    Joined:
    Apr 7, 2002
    Posts:
    5,587
    Likes Received:
    0
    Location:
    Rochester, N.Y
    Re: what the @!#@!$#@!$@!@!

    if still have to have someone else install it anyhow..
     
  6. bryguy00b

    bryguy00b 3/4 ton status

    Joined:
    Apr 7, 2002
    Posts:
    5,587
    Likes Received:
    0
    Location:
    Rochester, N.Y
    Re: what the @!#@!$#@!$@!@!

    does anyone have any ideas on what could be wrong? this is my DD..i mean i NEED this truck.... /forums/images/graemlins/1zhelp.gif
     
  7. gotmud?

    gotmud? 1/2 ton status

    Joined:
    Feb 23, 2002
    Posts:
    1,172
    Likes Received:
    0
    Location:
    up north
    Re: what the @!#@!$#@!$@!@!

    DAD...... /forums/images/graemlins/1zhelp.gif
     
  8. Panther

    Panther 1/2 ton status

    Joined:
    Aug 31, 2000
    Posts:
    845
    Likes Received:
    0
    Location:
    South Jersey
    Re: what the @!#@!$#@!$@!@!

    Well it seems both the ignition switched and unswitched (always hot) are both messed up. So start tracing the wire path back from the battery and look for loose connections or shorts. The clicking could be a loose connection sparking or an exposed wire arcing to ground.
     
  9. bryguy00b

    bryguy00b 3/4 ton status

    Joined:
    Apr 7, 2002
    Posts:
    5,587
    Likes Received:
    0
    Location:
    Rochester, N.Y
    Re: what the @!#@!$#@!$@!@!

    coluld this be any chance be my altinater? this mourning i came out..and everything worked, but was "low." the cargo light was low, but after i would start it up it would get bright again, and the heat will be low..and then sometimes when i stop or something will go on high again..the gauges work of and on..once and a while the temp gauge will get goofy..then it will go back to normal, the turn signals seemed to work this mourning, the wipers also worked but were a lot slower....i dunno its wierd.
     
  10. bryguy00b

    bryguy00b 3/4 ton status

    Joined:
    Apr 7, 2002
    Posts:
    5,587
    Likes Received:
    0
    Location:
    Rochester, N.Y
    Re: what the @!#@!$#@!$@!@!

    no the clicking was the turn signal blinker on the fuse box...but sometimes the light would not come on with it and the guages were moving with the rythem of it or something. but it wasnt doing it this mourning..
     
  11. Derf00

    Derf00 1/2 ton status

    Joined:
    Jul 25, 2000
    Posts:
    1,683
    Likes Received:
    0
    Location:
    Abilene, TX
    Re: what the @!#@!$#@!$@!@!

    Any chance your battery is bad? Had a recent experience where my battery which was a dual post had a bad side post connection. The battery would check out fine on the top posts, but when moved around the side post on the neg side was bad. It did some very strange things until we figured it out.
     
  12. bryguy00b

    bryguy00b 3/4 ton status

    Joined:
    Apr 7, 2002
    Posts:
    5,587
    Likes Received:
    0
    Location:
    Rochester, N.Y
    Re: what the @!#@!$#@!$@!@!

    well ya know..that was the first thing that came to me and my dads heads..we hooked it to a charger but it already checked out fine...but man all the symtoms act just like a low battery..when i get home ill swap it and see if anything turns out. it seems when i stop sometimes that will change things to..and when this first happened yesterday it happened when i was going on a HORRIBLE road..(pot hole city!!) and man that doesnt feel good in one of these trucks!! im not sure what else it could be though..the only other elctrical problems it had with it were simple things, and my horn doesnt work, but other than that i dunno....
     
  13. 83ZZ502_Jimmy

    83ZZ502_Jimmy 1/2 ton status

    Joined:
    Feb 7, 2001
    Posts:
    3,103
    Likes Received:
    0
    Location:
    Richmond, VA
    Re: what the @!#@!$#@!$@!@!

    Check and clean all grounds. Make sure you are grounded from battery to engine. Engine to frame. Battery to body.

    Most electrical problems are from bad ground.

    My .02,
    John /forums/images/graemlins/usaflag.gif

    p.s. on a sidenote, please give a brief description of the problem in the title of your post. The post title tells us nothing about the problem, plus some are turned off by it.
     
  14. bryguy00b

    bryguy00b 3/4 ton status

    Joined:
    Apr 7, 2002
    Posts:
    5,587
    Likes Received:
    0
    Location:
    Rochester, N.Y
    Re: what the @!#@!$#@!$@!@!

    sorry.. /forums/images/graemlins/crazy.gif i was just pretty pissed when i posted it lol...but anyway.. the battery to body ground is right at the front right..should i unhook them..and scrap the rust down to clean metal and then hook them back up?
     
  15. 83ZZ502_Jimmy

    83ZZ502_Jimmy 1/2 ton status

    Joined:
    Feb 7, 2001
    Posts:
    3,103
    Likes Received:
    0
    Location:
    Richmond, VA
    Thanks for the title change, I know how frustrating this can be. /forums/images/graemlins/smile.gif

    I would certainly clean off your connections, even if its not the problem it will help the charging system in the future. plus you've narrowed down your problems, and its easy to do.

    John /forums/images/graemlins/usaflag.gif
     
  16. bryguy00b

    bryguy00b 3/4 ton status

    Joined:
    Apr 7, 2002
    Posts:
    5,587
    Likes Received:
    0
    Location:
    Rochester, N.Y
    hmmm ya thats what it seems like its not charging or something..like there just isnt enough "juice"..but i mean it starts up and runs fine like it always does but nothing else seems to work right, at least some of the time lol.
     
  17. Grim-Reaper

    Grim-Reaper 3/4 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    7,385
    Likes Received:
    0
    Location:
    Atlanta
    Re: what the @!#@!$#@!$@!@!

    [ QUOTE ]
    sorry.. /forums/images/graemlins/crazy.gif i was just pretty pissed when i posted it lol...but anyway.. the battery to body ground is right at the front right..should i unhook them..and scrap the rust down to clean metal and then hook them back up?

    [/ QUOTE ]
    Right idea but the frames don't have a ground lead.
    The problem is the Ground from the back side of the passenger head to the fire wall is off.
     
  18. Grim-Reaper

    Grim-Reaper 3/4 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    7,385
    Likes Received:
    0
    Location:
    Atlanta
    Re: what the @!#@!$#@!$@!@!

    [ QUOTE ]
    sorry.. /forums/images/graemlins/crazy.gif i was just pretty pissed when i posted it lol...but anyway.. the battery to body ground is right at the front right..should i unhook them..and scrap the rust down to clean metal and then hook them back up?

    [/ QUOTE ]
    Right idea but the frames don't have a ground lead.
    The problem is the Ground from the back side of the passenger head to the fire wall is off.
     
  19. bryguy00b

    bryguy00b 3/4 ton status

    Joined:
    Apr 7, 2002
    Posts:
    5,587
    Likes Received:
    0
    Location:
    Rochester, N.Y
    Re: what the @!#@!$#@!$@!@!

    are you sure thats what it is? and sorry, but what do you mean by off? like adjusmtent or literally of? thanx!!
     
  20. Derf00

    Derf00 1/2 ton status

    Joined:
    Jul 25, 2000
    Posts:
    1,683
    Likes Received:
    0
    Location:
    Abilene, TX
    Re: what the @!#@!$#@!$@!@!

    He means that the connection is broken, bad, loose. Your description about the bad road is very indicative of a bad connection.
     

Share This Page