Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Wierd Transmission Problem.......

Discussion in 'The Garage' started by wasted wages, Jun 3, 2004.

  1. wasted wages

    wasted wages 3/4 ton status

    Joined:
    Dec 3, 2003
    Posts:
    9,194
    Likes Received:
    2
    Location:
    Dallas Texas
    Here's one for all you trans guy's ,,,

    My 97 GMC Yukon has this problem that starts only when the trans is hot and has been running down the road for a while.
    I think it's a 4L60E???

    When the trans is cool and driving arround town and in traffic it shifts normally, /forums/images/graemlins/thumb.gif,,,but when it's been driven at highway speeds,,,and then you stop and then go again the trans will shift HARD like it has a shift kit in it (even harder)(It really bangs hard into second) /forums/images/graemlins/angryfire.gif /forums/images/graemlins/angryfire.gif (It acts like the clutch packs are getting slammed with high pressure fluid) /forums/images/graemlins/yikes.gif
    and will continue to shift like that untill the truck is shut off and the truck sits about 10 minutes and then it shifts fine again,,,,, the "service engine soon" light comes on when this happens, does the trans throw a code that can be read?

    It does not slip,fluid has been changed twice in 84K miles.
    The trans works perfectly other than this hard shift problem,,,what gives?????? /forums/images/graemlins/dunno.gif /forums/images/graemlins/dunno.gif /forums/images/graemlins/dunno.gif
     
  2. Xtreme Off-Road

    Xtreme Off-Road Registered Member

    Joined:
    Apr 27, 2003
    Posts:
    48
    Likes Received:
    0
    Location:
    Ontario, Canada
    Sound like the EPC solenoid or line pressure regulator is sticking.
     
  3. 88sub4x4

    88sub4x4 1/2 ton status

    Joined:
    Sep 22, 2002
    Posts:
    792
    Likes Received:
    0
    Location:
    Long Island, NY
    You'll need to hook up a scan tool and it should send you in the right direction to figure it out. Most of the time if the tranny controller throws a code, it will tell the engine controller that it has a code and the engine controller will set the check engine light on, so make sure the scan tool can access the tranny controller and not just the engine controller.
     
  4. heavy4x4

    heavy4x4 1/2 ton status

    Joined:
    Aug 28, 2002
    Posts:
    3,270
    Likes Received:
    0
    Location:
    Delafield, Wisconsin
    [ QUOTE ]
    Here's one for all you trans guy's ,,,

    My 97 GMC Yukon has this problem that starts only when the trans is hot and has been running down the road for a while.
    I think it's a 460LE???

    When the trans is cool and driving arround town and in traffic it shifts normally, /forums/images/graemlins/thumb.gif,,,but when it's been driven at highway speeds,,,and then you stop and then go again the trans will shift HARD like it has a shifts kit in it (even harder)(It really bangs hard into second) /forums/images/graemlins/angryfire.gif /forums/images/graemlins/angryfire.gif (It acts like the clutch packs are getting slammed with high pressure fluid) /forums/images/graemlins/yikes.gif
    and will continue to shift like that untill the truck is shut off and the truck sits about 10 minutes and then it shifts fine again,,,,, the "service engine soon" light comes on when this happens, does the trans throw a code that can be read?

    It does not slip,fluid has been chenged twice in 84K miles.
    The trans works perfectly other than this hard shift problem,,,what gives?????? /forums/images/graemlins/dunno.gif /forums/images/graemlins/dunno.gif /forums/images/graemlins/dunno.gif

    [/ QUOTE ]

    /forums/images/graemlins/yikes.gif /forums/images/graemlins/yikes.gif /forums/images/graemlins/yikes.gif /forums/images/graemlins/yikes.gif

    My Dad's 1997 Chevy Suburban had THE EXACT same problem you just described. Just over a year ago it started doing it. The fluid and filter were changed - that didn't do it. My neighbor who's an auto-tech took it to his place of work and hooked it up to their computer - nothing. You know how we fixed it? Replaced it with a new tranny...that's what you have to do when it takes a dump on the freeway 400 miles from home! (This happened between 10,000 and 15,000 miles after the hard shifts started)

    Here's the only thing I can think to check: $1400 later with a new tranny, my Dad said to me, "you know what's weird, when I'm on the freeway, I'm running about 200 rpms less than with my old transmission." Ding Ding, it hit me...lockup. If I had to guess (and that's all it is - I wasn't able to verify this was the problem), I would say the torque convertor lock solenoid took a dump. I never thought to check that when we were having the problems. I'm thinking maybe the tranny is slamming its shifts as a response to it being too hot.

    /forums/images/graemlins/dunno.gif

    GOOD LUCK - hope you can save your tranny!

    -P.S, we weren't getting a "SES" light when the tranny was doing this - so maybe yours is throwing a code that can be read.
     
  5. wasted wages

    wasted wages 3/4 ton status

    Joined:
    Dec 3, 2003
    Posts:
    9,194
    Likes Received:
    2
    Location:
    Dallas Texas
    Re: Wierd Transmission Problem.......UPDATE....

    Thanks to all that responded /forums/images/graemlins/bow.gif /forums/images/graemlins/bow.gif /forums/images/graemlins/bow.gif,I posted this in the new sheet metal section and Burbinator had the same problem.
    It looks like the valve body has been revised with an steel bore that fixes a leak on one of the pistons /forums/images/graemlins/peace.gif /forums/images/graemlins/peace.gif /forums/images/graemlins/peace.gif,
    the leak results in slippage (no lock up?)this causes the ECM to default to full line pressure and results in the 1-2 slamshift. shutting off the truck must allow the ECM to reset and thats why the trans shifts OK again,,,makes sense to me,,,Well its off to the dealer and under the truck this weekend!! I'll post up the results when complete.
     
  6. wasted wages

    wasted wages 3/4 ton status

    Joined:
    Dec 3, 2003
    Posts:
    9,194
    Likes Received:
    2
    Location:
    Dallas Texas
    Re: Wierd Transmission Problem.......UPDATE....FINAL

    WOO-WOO! /forums/images/graemlins/woot.gif /forums/images/graemlins/woot.gif /forums/images/graemlins/woot.gif /forums/images/graemlins/woot.gif The valve body did the trick!!!! /forums/images/graemlins/woot.gif /forums/images/graemlins/woot.gif /forums/images/graemlins/woot.gif /forums/images/graemlins/woot.gif
    Thanks again to burbinator and to all that responded,,
    BTW,, the code is 1780
     

Share This Page