Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Wifes S10 running like crap!

Discussion in 'The Garage' started by bablazer73, Sep 19, 2004.

  1. bablazer73

    bablazer73 1/2 ton status

    Joined:
    Apr 4, 2000
    Posts:
    3,363
    Likes Received:
    0
    Location:
    upstate ny
    It started running rough and a hesitation just of idle a couple weeks ago. I started with the basics, since I hadn't done a tune up in the 2 years I've owned, i started there. It ran a little better, but still the hesitation. I let it go for a bit. Didn't have time to mess with it. But last weekend I drove it. I could barely drive it! The hesitation was wicked! i went to my buddies house and Used it Snap on scanner. Almost everything electronically checked out. but it was showing a lean condition(duh!) so we ran the O2 sensor test. which also says to "force a lean condition" by making a vacuum leak. so i pulled the P.C.V. line of. That usually will cause a leak........but got nothing?????
    The ports for the P.C.V. AND for the M.A.P sensor were plugged SOLID!! I had to remove the throttle body and drill out all the freakin carbon in the ports!!!

    Man, i have NEVER seen one as bad as this one!! I don't know how this even ran with the M.A.P. line plugged!! without any ck engine lights!! But she runs great now!

    Just thought i'de share.
     
  2. 86chevybanshee

    86chevybanshee 1/2 ton status

    Joined:
    May 15, 2004
    Posts:
    917
    Likes Received:
    0
    Location:
    beverly MA
    what year s-10 is it? my moms egr valve gets clogged up sometimes, hers is a 95 with the 4.3 vortec
     
  3. bablazer73

    bablazer73 1/2 ton status

    Joined:
    Apr 4, 2000
    Posts:
    3,363
    Likes Received:
    0
    Location:
    upstate ny
    This one is a 91.
     
  4. diesel4me

    diesel4me 1 ton status Premium Member

    Joined:
    Jul 24, 2003
    Posts:
    17,584
    Likes Received:
    945
    Location:
    Massachussetts
    We have seen several S-10's and other vehicles with the 4.3 V6 have the same symptoms--also the EGR valve on theese engines often carbon up badly,we had one truck the owner had brought it to 3 dealerships and several independent garages with no satisfation--his truck would start and run normally,sometimes for days with no problems--then suddenly it would start bucking,surging and stalling at stoplights,somtimes it would refuse to restart,usually after much cranking it would slowly come back to life,blowing charcoal soot out the tailpipe--we tried taking the catalitic converter off,new module,TPS,and a few other things till my friend noticed the PCV valve had no vacuum--we cleaned out all the ports and it ran much better,but it acted up again during the test drive(stalling again at red lights)so we pulled the EGR valve off(its behind the water pump in the center of the engine)and it had a bunch of carbon "balls"about the size of peas bouncing around under its pintle,ocasionally they would lodge under it and hold the EGR valve open,making it stall and run very rough--it took several cleanings before we got it all out,but its been 3 months and the owner is still happy his truck is running fine again--he even bought us all coffee and gave my friend a large tip for finding the problem /forums/images/graemlins/thumb.gifwhen the "experts"couldnt figure it out.We tried a used coil pack too,they often fail on theese engines-we also had tried replacing the "spider"thing under the intake with a known good used one,but it wasnt that,the dealer gets 400 bucks for that part /forums/images/graemlins/eek.gifand they claim when it goes south,that causes a lot of the carbon buildup in the engine-.I'm not that impressed with the 4.3 engine,or the S-10 series of trucks and the Astro vans--they suck to work on(ever do a starter on an S-10??)and they dont seem to be that rugged of an engine--I think they should have stuck with V-8's.. /forums/images/graemlins/dunno.gif
     

Share This Page