Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Wiper control NFG

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by shawnboy, Dec 9, 2001.

  1. shawnboy

    shawnboy 1/2 ton status

    Joined:
    Jun 22, 2001
    Posts:
    468
    Likes Received:
    0
    Location:
    Toronto, Canada, eh.
    "Dad, your windshield is too dirty," my son said. Gave them a squirt and wipe and the f***ers won't shut off. Stuck on fast mode. The switch on the steering colum is stripped of all wiper comand dunctions. I have a spare arm from my donor vehicle but that wasn't how I had planned to spend my Sunday. GRRRRRRRRR!!!!!!!!! Oh well, I guess I'll quit my bitchin' and break out the Haynes repair manual and get started. I hope I can find my steering wheel puller. Rant Rant Rant Rave Rave Rave etc...
    Shawnboy.

    <font color=red>If you are having too much fun it's probably illegal.</font color=red>
     
  2. Michael

    Michael 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,576
    Likes Received:
    0
    Location:
    Sherman, Texas
    That's what ya get for listening to your kids.....[​IMG] It sounds like it could be your "park" switch on the motor itself. They are very bad about getting stuck and not shutting off the motor. I'm not sure which wires to check on your model, but ya might try to track 'em down in your manual. Good luck!

    Michael[​IMG]
    <a target="_blank" href=http://www.jmartin.net/parker/goose.htm>www.jmartin.net/parker/goose.htm</a>
     
  3. hammer

    hammer 1/2 ton status

    Joined:
    Aug 29, 2001
    Posts:
    449
    Likes Received:
    0
    Location:
    Binghamton N.Y.
    I had major problem with both wipers and washer so I bought a new one $50 at autozone lifetime warrenty and $20 core took the core in when I bought it not enough of it left They took it anyway but the new one dosn't work right either. Found it had a bad wire in the washer. Maybe the old one did work? Check all wires and do a search about the schematics It was about a week ago somebody posted them

    <font color=red>Let me at it I can break it</font color=red>
     
  4. shawnboy

    shawnboy 1/2 ton status

    Joined:
    Jun 22, 2001
    Posts:
    468
    Likes Received:
    0
    Location:
    Toronto, Canada, eh.
    Nah, I wish it was thay easy. The clicky controls are stripped out so I have to replace the arm. PITA.
    Shawnboy.

    <font color=red>If you are having too much fun it's probably illegal.</font color=red>
     
  5. KRAZIE87K5

    KRAZIE87K5 1/2 ton status

    Joined:
    Feb 23, 2001
    Posts:
    3,369
    Likes Received:
    0
    Location:
    Chicago, IL
    Mine does something similar... I have no intermittant action from the wipers, just low and high. The squirters don't work, and the wipers dont make it back to park if you stop them early. IE, if you turn them off in the middle of the window, that is where they stay [​IMG]...

    What should I replace? I need the intermittant feature, and the squirters would be nice too [​IMG]. Anyone have an idea? Is there some kind of relay or something I can replace to cure this? Or do I just call up LMC Truck and order a new COMPLETE turn signal arm and install that?

    Thanks again - like always guys!

    -Dan

    <font color=red>GOT MUD???</font color=red>
    My license plate reads:<font color=blue> 8 YR SUV</font color=blue>
    Excite @Home SUCKS!
    454/TH400/NP205 - 14BFF/D60/w/ 4.10s
     

Share This Page