Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

wiper question

Discussion in 'The Garage' started by Big GMC truck, Apr 14, 2006.

  1. Big GMC truck

    Big GMC truck Registered Member

    Joined:
    Aug 23, 2005
    Posts:
    73
    Likes Received:
    0
    Location:
    California
    My wipers will only work on the high speed setting. Is this a wiper motor problem or a switch/ electrical/wiring problem. By the way, the truck is 22 years old. How do I troubleshoot this? Any help is appreciated.
     
    Last edited: Apr 14, 2006
  2. AV8

    AV8 Registered Member

    Joined:
    Oct 8, 2005
    Posts:
    45
    Likes Received:
    0
    Location:
    Winston Salem, NC
    I changed the wiper relay in my truck and fixed that problem.
     
  3. Big GMC truck

    Big GMC truck Registered Member

    Joined:
    Aug 23, 2005
    Posts:
    73
    Likes Received:
    0
    Location:
    California
    Where is the wiper relay located on a 1984 K1500?
     
  4. 1985_K5_Silverado

    1985_K5_Silverado 1/2 ton status

    Joined:
    Dec 21, 2005
    Posts:
    984
    Likes Received:
    0
    Location:
    Corn Country
    My '85 K5 GM shop manual troubleshooting chart says that if the wipers work, but have "Hi" speed only, it is likely to be:

    An open circuit in wire (#3 terminal on wiper motor) to wiper switch. Fix: locate and repair broken wire.
     

Share This Page