Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

wiper ?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by bablazer73, Jul 26, 2001.

  1. bablazer73

    bablazer73 1/2 ton status

    Joined:
    Apr 4, 2000
    Posts:
    3,363
    Likes Received:
    0
    Location:
    upstate ny
    I lost the wipers in my 84 pick-up today(it's raining!!). I checked the motor. It works fine. I have power, but lost hi and low ground control. I haven't traced the wires into cab yet. Does anybody have a color coded wiring diagram for this? I can trace the wires to the bottom of column from the motor but I don't know what wire feeds the column. I don't want to pull the column apart to trace wires if I don't have to.

    your right. I don't understand the jeep thing!
     
  2. Twiz

    Twiz 1/2 ton status

    Joined:
    Mar 8, 2001
    Posts:
    3,729
    Likes Received:
    0
    Location:
    Clearfield Ut.
    Try this; (hopefully, it works but....)

    -Check the wiper fuse (duh) That fuse should be hot with the key in the "run" position.
    -See if there is a white wire leading to the wiper switch- that should be the "hot" wire in to the switch. (again, hot with the key)
    -Check the purple wire for power- that should have power in high, no power in low or intermitant.
    -Check for power to the blue wire- that should have power in low and intermitan, but no power in high.

    Hopefully that should hold true with a '84, but I'm not sure. If G.M. runs their wireing the same way they run thier engines and tranys- almost everything is consistant.

    Good luck dude

    Twiztid

    oooh, don't forget to check your grounds too!
     
  3. bablazer73

    bablazer73 1/2 ton status

    Joined:
    Apr 4, 2000
    Posts:
    3,363
    Likes Received:
    0
    Location:
    upstate ny
    here is what I have done so far. I have constant power on the white wire with key on.(fuse is good)the gray wire is the low speed ground wire from the switch. the purple is the ground wire from the switch for the high speed. I have no ground going through these from the switch. I ran a jumper wire to the gray wire and grounded that so I could get to work. I can trace the wires to the connection on the column. but I don't know what wire feeds the ground to the switch.

    your right. I don't understand the jeep thing!
     
  4. Twiz

    Twiz 1/2 ton status

    Joined:
    Mar 8, 2001
    Posts:
    3,729
    Likes Received:
    0
    Location:
    Clearfield Ut.
    O.K. I'm confused. What do you mean "grounded"? The motor is grounded not the switch. The switch feeds power to the motor, it doesn't ground it.

    I'm thinking and speaking in the "Edison flow", pos. to negitive flow pattern.
    Not the true pattern- maybe thats whats got me confused?

    O.K. So we are on the same page; Hook the test light to the body (ground), then touch the test light to the white wire- to me that is the power in wire, as it works it's way back to the motor is the "flow of power." until it reaches the body again (grounded)- does that make any sense? Flowing Pos. to Neg.

    Twiztid

    Edited;
    O.K., It sounds like the switch is bad. --
    Man, is it tuff to diag things over the net!

    &lt;P ID="edit"&gt;&lt;FONT class="small"&gt;&lt;EM&gt;Edited by Twiztid on 07/26/01 09:22 PM.&lt;/EM&gt;&lt;/FONT&gt;&lt;/P&gt;<P ID="edit"><FONT class="small">Edited by Twiztid on 07/26/01 09:24 PM.</FONT></P>
     
  5. bablazer73

    bablazer73 1/2 ton status

    Joined:
    Apr 4, 2000
    Posts:
    3,363
    Likes Received:
    0
    Location:
    upstate ny
    the power is there all the time. Th ground side is the "switced" side. Your blower motor is the same way. power all the time and the ground goes through a step resister to contol speed. The swich is the resister on the wipers.

    your right. I don't understand the jeep thing!
     
  6. fr8train

    fr8train 1/2 ton status

    Joined:
    Aug 2, 2000
    Posts:
    1,712
    Likes Received:
    0
    Location:
    Maryland
    One more thing also. If you have intermitent wipers check the module on the top of your steering column to see if it is on its way out.

    Its not really AT the top of the column, more like opposite of the floor.
     
  7. bablazer73

    bablazer73 1/2 ton status

    Joined:
    Apr 4, 2000
    Posts:
    3,363
    Likes Received:
    0
    Location:
    upstate ny
    just your basic wipers. no delay.

    your right. I don't understand the jeep thing!
     
  8. Twiz

    Twiz 1/2 ton status

    Joined:
    Mar 8, 2001
    Posts:
    3,729
    Likes Received:
    0
    Location:
    Clearfield Ut.
    O.K. I'm lost. If you can wait till tomorrow, I'll check this out.

    We don't have any service manuals that dates back that far- so I'll ask some of the guys that do date bac.

    Twiztid
     
  9. Twiz

    Twiz 1/2 ton status

    Joined:
    Mar 8, 2001
    Posts:
    3,729
    Likes Received:
    0
    Location:
    Clearfield Ut.
    So, let me get this streight. Do you have power to the motor or to the switch first? (probably should have asked that to begin with)

    Twiztid

    Man, I'm going nuts over this. Damn things gona keep us both up late now!
     
  10. Twiz

    Twiz 1/2 ton status

    Joined:
    Mar 8, 2001
    Posts:
    3,729
    Likes Received:
    0
    Location:
    Clearfield Ut.
    Well, evidently. G.M. does NOT run their wireing the same way they run their engine/trannys- I check as meny S.M. as I could- they all had different diagrams and power/ground set ups. So, all that B.S. I said above does not apply. And I couldnt find any wireing diagram that even came close to a '84. -

    So;
    I asked our foreman. After he got done babbling about the "old days". He said the wiper motor has a relay init that is the most likly cause to inop wipers. He also metioned the canceling cam had problems too.

    Man, tring to diag stuff over the net is a b!tch! - At least I gave it a shot-

    Twiztid
     
  11. Pure Insanity

    Pure Insanity 1/2 ton status

    Joined:
    Mar 17, 2001
    Posts:
    4,579
    Likes Received:
    0
    Location:
    Dade City, Florida
    OK guys heres 1.......... I turned on the wipers on mine several months ago, (after bragging on not having the phantom wipers) and they moved REAL slow to all the way up to the top where they would return, and they stopped. Being as I am having the tranny problems it has not been at the top of my list of things to care about, but I reckon Ill need to fix it sooner or later, and living in Fla it rains EVERYDAY! I havent even begun to check this out but it would be good to know if anyone else had this happen. Its an 86 and a silverado so Im assuming it has delay.( having never really driven the truck I really dont know)

    Out of 100,000 sperm, YOU were the fastest?? [​IMG]
     

Share This Page