Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Won't Start

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by KapeKodK5, Nov 11, 2000.

  1. KapeKodK5

    KapeKodK5 Registered Member

    Joined:
    Mar 3, 2000
    Posts:
    44
    Likes Received:
    0
    Won\'t Start

    I need help. I have a won't start problem with my 1990 k-5.
    the other day i started my Blazer and about 10 seconds later, it went completely dead. I then restarted it and it ran fine for 2 days. Today i tried to start it and nothing happened. The battery is fine, the key on position lights up the dash but, when i turn the key to start, All the lights on the dash go out and the battery gauge reads 0. There is no clicks like from a bad solenoid. Just silence. I am lost. I replaced the ignition switch and that was not the problem.. I need help i hope someone has an answer.....
     
  2. jimmyjack

    jimmyjack 1/2 ton status

    Joined:
    May 11, 2000
    Posts:
    2,290
    Likes Received:
    0
    Location:
    Tucson Az
    Re: Won\'t Start

    Check the negative cable to be sure it is grounded correctly. Could just be a bad starter too. Good Luck

    creepin' and crawlin'

    Jim
     
  3. 90K5

    90K5 1/2 ton status

    Joined:
    Jun 1, 2000
    Posts:
    3,719
    Likes Received:
    0
    Location:
    Lubbock, TX
    Re: Won\'t Start

    It sounds like you may need a new ignition module. That happened to my '90 this summer and thats what was wrong.

    90K5
     
  4. OFFRDK5

    OFFRDK5 1/2 ton status Premium Member

    Joined:
    Oct 2, 2000
    Posts:
    1,881
    Likes Received:
    2
    Location:
    Central IL
    Re: Won\'t Start

    Might try finding your starter and checking its cables. Make sure they are all tight. You might have one that is falling off and causing some problems. You might also have the starter checked. Check all your battery connections, WATCH THE POSITIVE AND YOUR CONNECTION TO THE BLAZER BODY I FOUND THIS OUT THE HARD WAY, and make sure they are not corroded or getting bad connections. Check the fuse box too...never know what something will cause. Check your ignition (distrib, spark plug wires)system. Make sure all cables look good and are making good connection. Hope something here helps.

    SK-15
    J**P...it's whats for dinner!
    http://SK-15.coloradok5.com
     
  5. KapeKodK5

    KapeKodK5 Registered Member

    Joined:
    Mar 3, 2000
    Posts:
    44
    Likes Received:
    0
    Re: Won\'t Start

    You said my problem might be an ignition module which you have changed, where is that located.. I just changed the on out on my steering column "underneath the dash" unless you are talking about something else.. let me know thanks...
     
  6. OFFRDK5

    OFFRDK5 1/2 ton status Premium Member

    Joined:
    Oct 2, 2000
    Posts:
    1,881
    Likes Received:
    2
    Location:
    Central IL
    Re: Won\'t Start

    Check underneath..from the center of your distrib cap there will be the coil wire..check and make sure its hooked up and functioning properly. Check all the wires underneath the dash. How long ago was the switch out of the coloumn? If you just did it you have a loose wire somewhere. Check everything...problems pop up in the strangest places!!

    SK-15
    J**P...it's whats for dinner!
    http://SK-15.coloradok5.com
     

Share This Page