Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

WTF is going on?!?

Discussion in 'The Garage' started by Wingnutt, Feb 26, 2004.

  1. Wingnutt

    Wingnutt 1/2 ton status

    Joined:
    Feb 20, 2000
    Posts:
    324
    Likes Received:
    0
    Location:
    NOVA
    OK I talked to Holley this morning about that TBI and the rep said that I needed to reduce the fuel pressure a bit; no problemo, got home tonight and followed his instructions to the letter. After a bit of tweaking, everything was great, idled at 800rpm and 650 in gear. /forums/images/graemlins/thumb.gif So thinking everything was OK, I got ready to button everything back up. After I put the tools up, I thought what the heck, let me fire this thing once more before I road tested it. That’s when things got interesting, the dang thing wouldn’t idle below 1600rpm! /forums/images/graemlins/yikes.gif I backed the idle adjusting screw all the way out....no dice. Then I sprayed WD40 around the base to check for vaccum leaks, nada. After that, I unhooked the TPS so that the TBI would be completely isolated from the computer...same result.

    Does anybody have ANY idea of what could have happened. This thing is starting to get on my last nerve! /forums/images/graemlins/angryfire.gif TIA
     
  2. Confedneck

    Confedneck 3/4 ton status

    Joined:
    Nov 1, 2002
    Posts:
    5,236
    Likes Received:
    0
    Location:
    Lehigh Acres, Florida
    sounds like maybe something like debris got jammed in the butterflies?? does the holley TBI use an IAC??
     
  3. 75-K5

    75-K5 3/4 ton status

    Joined:
    Apr 28, 2002
    Posts:
    5,353
    Likes Received:
    0
    Location:
    Anderson, Indiana
    Haha, the same thing happened to my XJ after I decided to power wash the engine compartment. I freaked out, then just said heck with it and drove it like it was. Less than a mile down the road it was back to normal. Can't hurt to try. /forums/images/graemlins/waytogo.gif
     
  4. Wingnutt

    Wingnutt 1/2 ton status

    Joined:
    Feb 20, 2000
    Posts:
    324
    Likes Received:
    0
    Location:
    NOVA
    Ya, it uses an IAC and I had that disconnected too ,it's supposed to be a direct replacement. I didn't see anything in the butterflys, they would colse so far they rubbed against the venturi walls.

    I reved it up several times, smae thing. I'm gonna try to get in touch with Holley this morning. One thing that I can say about them, so far they've had great tech support.

    Anybody else?

    Thanks
     
  5. Grim-Reaper

    Grim-Reaper 3/4 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    7,385
    Likes Received:
    0
    Location:
    Atlanta
    The original stuff on adjusting the TPS is wrong inthe instructions. It gives those sort of symptoms. I know two people with the holly stuff that had the same issue.
     
  6. Wingnutt

    Wingnutt 1/2 ton status

    Joined:
    Feb 20, 2000
    Posts:
    324
    Likes Received:
    0
    Location:
    NOVA

Share This Page