Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

WTF.... this suburban is pissing me off

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by muddysub, Aug 17, 2004.

  1. muddysub

    muddysub 1 ton suburban status Staff Member Moderator GMOTM Winner

    Joined:
    Jun 23, 2001
    Posts:
    10,451
    Likes Received:
    489
    Location:
    my garage, Henderson, NV
    ok i went to put my stereo face back on this morning and i turn the key on and the dash lights (check engine, batt... etc) took like 30 seconds to turn on and theres no power to the stereo, ggrrrrrrr, this [darn] truck is pissing me off!
     
  2. muddysub

    muddysub 1 ton suburban status Staff Member Moderator GMOTM Winner

    Joined:
    Jun 23, 2001
    Posts:
    10,451
    Likes Received:
    489
    Location:
    my garage, Henderson, NV
    AAAAAAAAAAAAAAAAAAAAAAAAAAHHHH i hate this! part of me wants to go make this truck run and part of me wants to get rid of the damn thing!!!! if i had my way none of this would be happening, cuz it would have gone to phx with me ans never would have sat for a year and a half... but no mom and dad wouldnt let me bring MY truck with me!!!!!! i can see it now im gonna be fixing [darn] and chasing problems for months now!!!
    GGRRRRRRRRRRRRRRRRRRRRRRRRRRRRRR /forums/images/graemlins/angryfire.gif /forums/images/graemlins/angryfire.gif /forums/images/graemlins/angryfire.gif /forums/images/graemlins/angryfire.gif /forums/images/graemlins/angryfire.gif /forums/images/graemlins/angryfire.gif
     
  3. cegusman

    cegusman 3/4 ton status

    Joined:
    Apr 25, 2001
    Posts:
    6,793
    Likes Received:
    0
    Location:
    Houston/Katy, Tx
    I'll give you $3.50 for it /forums/images/graemlins/dunno.gif
     
  4. muddysub

    muddysub 1 ton suburban status Staff Member Moderator GMOTM Winner

    Joined:
    Jun 23, 2001
    Posts:
    10,451
    Likes Received:
    489
    Location:
    my garage, Henderson, NV
    lol sorry i dont think im getting rid of it... just ranting a litte bit. the stereo is secondary, getting it running, reg'd and insured is priority.
     
  5. SF87K5

    SF87K5 1/2 ton status

    Joined:
    Oct 27, 2002
    Posts:
    1,105
    Likes Received:
    0
    Location:
    Stedman, North Carolina
    is your battery good and it the posts and cables clean?
     
  6. muddysub

    muddysub 1 ton suburban status Staff Member Moderator GMOTM Winner

    Joined:
    Jun 23, 2001
    Posts:
    10,451
    Likes Received:
    489
    Location:
    my garage, Henderson, NV
    batt was just installed, brand new, i have no idea why theres no power to the stereo...
     
  7. k20

    k20 3/4 ton status

    Joined:
    Sep 9, 2001
    Posts:
    5,068
    Likes Received:
    0
    Location:
    Mineral Springs, NC
    is it just the stereo? I mean will the engine turn over and all? Check obvious, fuses etc, maybe hook a power wire from fuse panel to the radio and see if it will turn on.
     
  8. Pookster

    Pookster 1/2 ton status

    Joined:
    Nov 21, 2000
    Posts:
    3,195
    Likes Received:
    0
    Location:
    NYC, NY, USA
    sounds like your main ground could be coroded... i've had the same thing happen on GM cars when they sat for a while.

    check the main ground, then pluck and reseat all the fuses.

    There are sometimes also various random grounds throughtthe dash- check those as well. A small amount of oxidation will cause bad connections.
     
  9. muddysub

    muddysub 1 ton suburban status Staff Member Moderator GMOTM Winner

    Joined:
    Jun 23, 2001
    Posts:
    10,451
    Likes Received:
    489
    Location:
    my garage, Henderson, NV
    yeah its just the stereo, ill go through it tomorrow and check everything, might have killed a fuse in removing and reinstalling the batt once a month when i would start it up.
     

Share This Page