Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Wtf?!?

Discussion in 'The Garage' started by LEEREED123, Apr 23, 2007.

  1. LEEREED123

    LEEREED123 1/2 ton status

    Joined:
    Jun 29, 2006
    Posts:
    384
    Likes Received:
    0
    Location:
    BFE, Ga
    Strangest thing happened on the way to work today in my 91. the cruise control stopped working and my abs light started flashing erraticly.
    what gives?!?
    any ideas?
     
  2. pauly383

    pauly383 Daddy383 Staff Member Moderator

    Joined:
    Jul 22, 2001
    Posts:
    16,217
    Likes Received:
    1
    Location:
    Mesa , Arizona USA
    Brake switch :dunno: First thing I'd check .
     
  3. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,981
    Likes Received:
    189
    Location:
    Roy WA
    The erratic flashing is probably a code. For the ECM trouble codes it was long and short flashes of the light to differentiate between the first and second digit of the code.
     
  4. LEEREED123

    LEEREED123 1/2 ton status

    Joined:
    Jun 29, 2006
    Posts:
    384
    Likes Received:
    0
    Location:
    BFE, Ga
    actually, it's not flashing like a diagnostic code, just like a flickering light bulb. checked diagnostic codes and nothing is showing.
     
  5. JEBSR

    JEBSR 1/2 ton status

    Joined:
    Dec 23, 2004
    Posts:
    1,541
    Likes Received:
    0
    Location:
    Clarksville, TN
    Speed sensor is the first thing that comes to mind. As far as I know it's the only thing that the cruise and the ABS has in common.
     
  6. LEEREED123

    LEEREED123 1/2 ton status

    Joined:
    Jun 29, 2006
    Posts:
    384
    Likes Received:
    0
    Location:
    BFE, Ga
    ok, the light flashes like crazy, but if i unplug the abs module, it goes out.
    does that help?
     
  7. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,981
    Likes Received:
    189
    Location:
    Roy WA
    If speed sensor was screwed up, the speedometer wouldn't work either.

    I'd check the brake switch, cruise and ABS are the only thing in common there, since the brake switch will turn off cruise.
     
  8. JEBSR

    JEBSR 1/2 ton status

    Joined:
    Dec 23, 2004
    Posts:
    1,541
    Likes Received:
    0
    Location:
    Clarksville, TN
    not necessarily, if a segment on the tone ring is bad or it is an intermittent "no read" problem then the speedo may still work, it would probably jump on occasion though.
     
  9. LEEREED123

    LEEREED123 1/2 ton status

    Joined:
    Jun 29, 2006
    Posts:
    384
    Likes Received:
    0
    Location:
    BFE, Ga
    well, seems like it's down to the brake switch and VSS.
    the brake switch is $6, and the VSS is 95.
    i'll try the brake switch 1st.
    i'll let you know!
    thanks!
     
  10. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,981
    Likes Received:
    189
    Location:
    Roy WA
    You should be able to test the brake switch, it's a simple open/closed piece. It may just be out of adjustment.
     
  11. dhcomp

    dhcomp 3/4 ton status Premium Member

    Joined:
    Mar 17, 2001
    Posts:
    9,862
    Likes Received:
    295
    Location:
    Truckee, CA
    i bet on speed sensor.
     

Share This Page