Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

zero rate add-leaf/add a leaf

Discussion in 'The Garage' started by blackblazer717, Dec 19, 2004.

  1. blackblazer717

    blackblazer717 1/2 ton status

    Joined:
    Jul 1, 2004
    Posts:
    470
    Likes Received:
    0
    Location:
    massachusetts
    got a quick question,
    i know the Zero rates come with new centering pins but will the pins be long enough to put a regular add a leaf in with the zero rates as well?
    the springs are stock w/ shackle flip, and i want to rid my Saggy Butt.
    thanks
    luke
     
  2. Hossbaby50

    Hossbaby50 3/4 ton status

    Joined:
    Sep 1, 2001
    Posts:
    8,972
    Likes Received:
    0
    Location:
    Peoria, AZ
    Yes, it should be. I had a 2" add a leaf and a 1" zero rate in my rear spring pack for a couple years.

    Harley
     
  3. 78blazaer

    78blazaer Registered Member

    Joined:
    Aug 15, 2002
    Posts:
    36
    Likes Received:
    0
    I just installed a zero rate kit on my 78 Blazer and I tell you it was a learning experience. Let me first answer your question. The center pin is long enough, too long actually that I had to cut the the center pin about 1/4 of an inch off to avoid hitting the u-bolt plate. Anyway going back to my experience. First, I painted the blocks with rusholeum to avoid rust from contaminating the bare metal. I started on the passenger side, pulled the passenger wheel off (BIG MISTAKE), I couldn't find a jack and/or jack stand long enough for my truck to get the weight out of the springs. I ended up placing a jack under the axle tube and jack stand under the frame. I then slowly lowered the jack (wheels off) to a point that the brake drum was almost touching the ground to get the weight off the spring. What a pain in the @ss. Finnally I got the spring out, bolted the zero rate using the center pin/bolt that came with the kit. I started puting the lift spring back on, mounted both ends of the spring and started jacking the axle up. The axle must have moved an inch backward. The spring center bolt wasn't lining up with the axle plate, it was an inch off!!! I tried pushing the the massive GM 14FF an inch forward by myselft to center it, almost broke my back to no avail. After several attemps, jacking the axle up and down etc.. it finnally lined up, wheew. After serveral hours, and almost drained out of strenght, I managed to get the passenger side block done. I still have the driver side to do next. So after a deep breath, I said to myself, there's no way I am going to go through the same challenges again. So I left the wheel on instead, yes wheel on and removed the ubolts. I then jacked up the spring (yes only the spring). As soon as I got enough clearance to remove the center pin/bolt, I placed a jack stand under the lift spring for safety (I like the idea of having 10 fingers). You will need a vice-grip or some sort to hold the pin from turning while you unscrew the retaining nut. Mine was so rusty, it took me a while and ended up cutting off the retaining nut using a grinder/cutting tool. Once the center pin was off, I simply bolted the new block using the new center pin that came with the kit, lowered the spring back to the axle, put the ubolt back on and wolla! I'm done!!! Remember, you may have to cut the center pin a bit short to avoid hitting the plate. Good luck and I hope you get a change to read this post before you actually do the work. Remember, you don't have to pull the wheels off and always use a jack stand. Enjoy and I am sure you'll have fun doing it. I did.
     
    Last edited: Dec 20, 2004
  4. Desert Rat

    Desert Rat Fetch the comfy chair

    Joined:
    Oct 19, 2002
    Posts:
    16,250
    Likes Received:
    3
    Location:
    Tri-Valley, NorCal
    I just did mine on my 76 Blazer as well. I have a 4x4iron rear bumper with the two shackles on it. I have a cherry picker so I hooked a chain to the two shackles and used it to lift the truck up. I placed a floor jack under the rear Corp14ff to move it up and down. I removed the tires for ease of access but I suppose I could have left them on. I don't have the driveshaft in so the axle didn't move, but it did rotate a bit. I also had to cut the center pin once it was installed so it wouldn't hit the spring plate. The instructions recommended drilling a hole in the spring plate but I found it easier to enlist the aid of Mr. Sawzall. I probably should have painted the zero rates, but I left them bare metal.
     
  5. cbbr

    cbbr 1 ton status GMOTM Winner

    Joined:
    Jul 17, 2004
    Posts:
    14,681
    Likes Received:
    0
    Location:
    High velocity, Low altitude
    They weren't long enough for mine in the rear (3/4 ton=big spring pack).Got some Grade 8's, shaved the edges so they would fit flush in the hole in the top of the axle and they work great.
     
  6. blackblazer717

    blackblazer717 1/2 ton status

    Joined:
    Jul 1, 2004
    Posts:
    470
    Likes Received:
    0
    Location:
    massachusetts
    well thanks for the help all. i
    just needed to know if the zero rates pin was long enough for a 1/2 ton blazer spring and a 2inch add a leaf. so i suppose it will work and ill be painting the zero rate because i hate rust. makes me mad
    luke.
     

Share This Page