CK5 Network
Repairing, restoring or modifying your ride just got a whole lot easier!

1997 tahoe .Running rough..ses light on

bckinblk

1/2 ton status
Joined
Jun 12, 2002
Posts
305
Reaction score
0
Location
bristol connecticut
I started it yesterday and it ran rough .Like its skipping.Ses light stays on..I can't find anything wrong ..Oil looks normal ..all plugs seem good..Is there a way to jumper pins like my 88 k-5 .?? Thanks for any info...
 

marine_enlisted

1/2 ton status
Joined
Sep 29, 2002
Posts
658
Reaction score
0
Location
Stafford, VA
You have to have a OBDII code scanner to get codes and trun off SES lamp on your ride. Autozone will pull your codes and reset the lamp for free. /forums/images/graemlins/thumb.gif
 

bckinblk

1/2 ton status
Joined
Jun 12, 2002
Posts
305
Reaction score
0
Location
bristol connecticut
I went to auto zone and had it scanned .It threw 3 codes 2 for number 5 cyl misfire and 1 for tps low..So I replaced the tps and put in new plugs and wires .And it still runs like [darn]..I also noticed that the temp gage is running hotter than usual and it smells like antifreeze..What else could it be??? Thanks again... /forums/images/graemlins/confused.gif
 

heavy4x4

1/2 ton status
Joined
Aug 28, 2002
Posts
3,270
Reaction score
0
Location
Delafield, Wisconsin
Sounds like a blown head-gasket. You're probably getting coolant in the #5 cylinder and thus the hotter running-temp, anti-freeze smell, and crappy performance.
 

HarryH3

1 ton status
Author
Joined
May 31, 2000
Posts
10,384
Reaction score
4
Location
Georgetown, TX
It could be as simple as a leaking intake manifold gasket allowing coolant into the cylinder. The Vortec 350's are infamous for that little design "feature". /forums/images/graemlins/frown.gif
 

bckinblk

1/2 ton status
Joined
Jun 12, 2002
Posts
305
Reaction score
0
Location
bristol connecticut
After days of research that is what I am thinking is the problem...The only dilemma I see is those new style fittings at the end of the gas lines and water spout in the intake manifold..What is the best way to remove them without destroying em??Anyone know??
 

bckinblk

1/2 ton status
Joined
Jun 12, 2002
Posts
305
Reaction score
0
Location
bristol connecticut
I just bought the new gaskets and a new fuel pressure regulator .I will install them sometime this weekend..Thanks for the help... /forums/images/graemlins/thumb.gif
 

bckinblk

1/2 ton status
Joined
Jun 12, 2002
Posts
305
Reaction score
0
Location
bristol connecticut
Update..Ok today I took apart the upper and lower intakes.I found that indeed the gaskets were leaking in 2 spots so that takes care of my antifreeze leaks.But inside the plenum there is a spider looking thing that has the fuel injectors coming off of it .All the injectore look clean exept for # 5 is dirty and blackened ..This is my misfire problem I bet..But what the hell is this thing called?? Do I have to change the whole unit or can I just change #5 wire?? Thanks again for any info in advance.. /forums/images/graemlins/thumb.gif
 

bckinblk

1/2 ton status
Joined
Jun 12, 2002
Posts
305
Reaction score
0
Location
bristol connecticut
Cool thanks..The only thing I need now is the correct bolt pattern and torque specs and I should be able to put it back together by the weekend..Thanks again /forums/images/graemlins/thumb.gif
 
Top Bottom