Just another burb. (Getting a new heart soon)

Little lower, little cooler, bigger sounds.

shady

1 ton status
Premium Member
Joined
Jul 31, 2010
Posts
12,273
Reaction score
8,793
Location
iowa
Nope. Never even tried.


Im starting to wonder if the limp mode thing is a transmission sensor going bad.
I've heard that if they sense slip, they'll do the low power thing.
Engine runs smooth and awesome. It just goes into a low power mode once in a while, accompanied by the check engine light.
Stop, shut it off, start it back up, and continue on your way. :dunno: .
It's happened driving ng down the highway on flat ground in cruise. And sitting in a parking lot idling in park.....?
Not often. Just enough here and there to bug me.
Like 7-8 times since I bought it.
 

shady

1 ton status
Premium Member
Joined
Jul 31, 2010
Posts
12,273
Reaction score
8,793
Location
iowa
Got my steam line stuff done. Now I just hope my home brew blocks don't leak.

I'd like to have a couple more stock rear block off ones if I can find them. I threaded and blocked the old skinny steam lines with set screws, then epoxied them in.
And cut a flat spot, then drilled and threaded the rear ones.

IMG_20210317_123002643.jpg

IMG_20210317_122913989.jpg

IMG_20210319_205646351.jpg

IMG_20210319_205639125.jpg
 

JoshHefnerX

1/2 ton status
Premium Member
Joined
Jan 7, 2015
Posts
4,807
Reaction score
3,487
Location
Glendale, AZ
You do know they make some steam pipes for those block so they have to fit properly under the intake.
 

LLeff

1/2 ton status
Premium Member
Joined
Jun 13, 2018
Posts
106
Reaction score
195
Location
Illinois
i should have a few of the stock block off ones for the rear of the head kicking around somewhere
 

shady

1 ton status
Premium Member
Joined
Jul 31, 2010
Posts
12,273
Reaction score
8,793
Location
iowa
That would be cool. Let me know if you do happen to find them.
I'm pretty confident that the rear ones I did will not leak. I'm not totally sold on them front ones though.
 

Chevy305

6 Lug 14bsf Status
Premium Member
GMOTM Winner
Joined
Jan 23, 2006
Posts
12,362
Reaction score
1,643
Location
New Hampshire
These fit under the intake. And this was like $8. Instead of $125+
I've seen them double that price and I've been thinking to myself, who in the world would spend so much money on steam vents?
 

shady

1 ton status
Premium Member
Joined
Jul 31, 2010
Posts
12,273
Reaction score
8,793
Location
iowa
Couple of lines that coolant runs through and it's more expensive than a Trailblazer SS intake and fuel rail. :doah:
If I spend money it'll be on MO powa.
 

shady

1 ton status
Premium Member
Joined
Jul 31, 2010
Posts
12,273
Reaction score
8,793
Location
iowa
When it comes to LS I've found that a LOT of prices are flat stupid.

Pulling one out of a JY, slapping it in and running it is quick enough cheap easy power upgrade. As soon as you touch it beyond that..$$$$.

I found oil pans $1000+ :rolleyes:
Shear crazyness.
 

shady

1 ton status
Premium Member
Joined
Jul 31, 2010
Posts
12,273
Reaction score
8,793
Location
iowa
The cheapest cam on summit is more expensive than a lot of whole cam kits for other engines.
Just a stick vs stick, lifters, springs, retainers. :doah:
 

shady

1 ton status
Premium Member
Joined
Jul 31, 2010
Posts
12,273
Reaction score
8,793
Location
iowa
No, it's the same reason trucks cost so much...... Because they can. And they know people will pay for it.
 

centexk5

1/2 ton status
Premium Member
Joined
Jun 23, 2019
Posts
1,954
Reaction score
2,744
Location
Georgetown, TX
Exactly. Demand is high, price is high. LS’s are the most popular engine swap out there. There’s a huge market and huge demand for parts. So they’ll charge what they can get. It’s capitalism.
 

beags86

Eastbound and Down
Premium Member
Joined
Jan 18, 2011
Posts
14,509
Reaction score
19,459
Location
In my shop
Nope. Never even tried.


Im starting to wonder if the limp mode thing is a transmission sensor going bad.
I've heard that if they sense slip, they'll do the low power thing.
Engine runs smooth and awesome. It just goes into a low power mode once in a while, accompanied by the check engine light.
Stop, shut it off, start it back up, and continue on your way. :dunno: .
It's happened driving ng down the highway on flat ground in cruise. And sitting in a parking lot idling in park.....?
Not often. Just enough here and there to bug me.
Like 7-8 times since I bought it.

Maybe when you send that old 6.5 off the that big junkyard in the sky you can post a video?
Would love to watch a claw pick it off the trailer and toss that hunk into the junk pile.
Bonus points if there is a shredder JY close... better yet, if there is let me know and I'll come watch and we can cheers ridding the world of another worthless gm diesel.
 

shady

1 ton status
Premium Member
Joined
Jul 31, 2010
Posts
12,273
Reaction score
8,793
Location
iowa
Lol. I'll probably sell it to someone who will treat it with the love they have for em.... Or nobody will want it and it'll get sent to the scrap yeah... But all I have here is a dude with a huge magnet and a big pile. So no worthy send off vids.
 

beags86

Eastbound and Down
Premium Member
Joined
Jan 18, 2011
Posts
14,509
Reaction score
19,459
Location
In my shop
Lol. I'll probably sell it to someone who will treat it with the love they have for em.... Or nobody will want it and it'll get sent to the scrap yeah... But all I have here is a dude with a huge magnet and a big pile. So no worthy send off vids.
There probably only 2 people in this world that would want it. Maybe 3. All on here. To bad you don't own a boat.
 

campfire

Adventure is out there!
Premium Member
Joined
Jun 7, 2013
Posts
25,178
Reaction score
14,352
Location
Northwoods Wisconsin / da U.P.
If he actually did scrap it, there's a 5% chance I could use the serpentine setup. But would I ever get around to installing it? Who knows? :dunno:
 

shady

1 ton status
Premium Member
Joined
Jul 31, 2010
Posts
12,273
Reaction score
8,793
Location
iowa
You don't want it lol. I've been going through issues with that exact thing. Recently it popped a seal, sprayed anti freeze on the belt, which slipped off on the new tensioner and wrapped around the fan. Fixed it all.... Then the belt randomly came off again. Checked out all the pulleys, put it back on, and it did it again within that day. Said fork the gates tensioner pulley with no side ridges And got a new stock style figuring it would stay on better, along with a new belt. Worked for about a month, and yesterday it chit the belt again idling. Destroyed the belt this time. I'm not replacing it.

All pulleys are good, nothing seems to have bad bearings, it all lines up and seems to operate smoothly. But for some reason it kicks a belt out of nowhere once in a while :dunno: .
I'm seriously debating cranking the turbo pressure as far as it'll go and flat footing it in park until it fails hard lol. Then push it in the shop and tear it apart.

It won't be driven under diesel power again except to move it inside the shop.
 
Top Bottom